Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#50 MSVCP71.dll missing - Win7

Windows Binary
closed-fixed
ianaré
install (9)
7
2014-08-21
2010-02-26
Devin
No

Hi, I installed the app using admin privlages, but it won't run, giving me an error about a missing dll. I've run it as admin already and that still gives me the same error. Error:
---------------------------
metamorphose.exe - System Error
---------------------------
The program can't start because MSVCP71.dll is missing from your computer. Try reinstalling the program to fix this problem.

I've tried reinstalling but nothing, still doesn't work. Here's the log file:
Traceback (most recent call last):
File "metamorphose.py", line 51, in <module>
File "wx\__init__.pyo", line 45, in <module>
File "wx\_core.pyo", line 4, in <module>
File "wx\_core_.pyo", line 12, in <module>
File "wx\_core_.pyo", line 10, in __load
ImportError: DLL load failed: The specified module could not be found.

Any ideas? There was a previous post about a similar Vista bug, but I'm not about to download dlls from some random site...

Discussion

  • ianaré
    ianaré
    2010-02-26

    Thanks for your report. I'm including this file in the installer, but it could be for an older version of windows (I believe win2000 would complain).

    Try going to the Métamorphose program folder and delete it (this file might already be present on your system). If that works, then I will change the installer for it not to install it on win 7.

    If that doesn't work, I will download the latest version from MS and package it with the app. We can then test that and go from there.

    - ianaré

     
  • ianaré
    ianaré
    2010-02-27

    • assigned_to: nobody --> ianare
    • priority: 5 --> 7
    • status: open --> open-accepted
     
  • Devin
    Devin
    2010-02-27

    Thanks for the quick reply! I installed it on my other win7 machine and it worked fine. When looking in the install folder there is only a MSVCR71.dll file, not a MSVCP71.dll file. Maybe my second computer is messed up somehow? That dll might not be registered by windows for some reason. I've ran scv /scannow which should repair system files but it didn't detect any missing files.

    Could you include it in the installer? Or possibly point me in the right direction for this file so I can grab it myself.

     
  • ianaré
    ianaré
    2010-02-28

    Did some research on this issue, the file does need to be included as it is not included normally with windows ... I will make a new release containing both files and make available for testing. Thanks for help on getting this to work ....

     
  • Devin
    Devin
    2010-03-01

    Awesome, I'll test it on my machine on your next release and report back whether it works or not.

    Thanks!

     
  • ianaré
    ianaré
    2010-03-03

    Testing new release. Some changes were made to the installer. Please verify that
    1) installer asks for admin privileges
    2) msvcp71.dll and MSVCR71.dll are present in the metamorphose2 folder
    3) no errors are given about missing dlls.

    http://downloads.sourceforge.net/file-folder-ren/metamorphose2_0.6.6_setup.exe

    Thanks a bunch !

     
  • ianaré
    ianaré
    2010-03-03

    oh, forgot, make sure to completely uninstall (including user files) before installing the new version.

     
  • ianaré
    ianaré
    2010-03-03

    • labels: --> 826593
     
  • ianaré
    ianaré
    2010-03-03

    • labels: 826593 --> install
     
  • Devin
    Devin
    2010-03-04

    Works great! Installer asked for admin rights and the program launched without any problems. Both DLLs are in the metamorphose2 folder.

    Thanks for the fix!

     
  • ianaré
    ianaré
    2010-03-04

    Great! Thanks for your help.

     
  • ianaré
    ianaré
    2010-03-04

    • status: open-accepted --> closed-fixed