#2 no aircraft listed

closed
nobody
None
5
2006-04-19
2006-02-16
Anonymous
No

Just updated from the cvs version of fgrun today and
when i run it i get a blank screen where the aircraft
used to be listed.
Everything else is ok i just cant select any aircraft.

I'm using Linux and the latest cvs FG

My email is justin@smithies.me.uk

Discussion

  • a1270
    a1270
    2006-03-25

    Logged In: YES
    user_id=1484942

    I'm having the smae problem. As i recall it happened when
    FlightGear was moved from /opt to /usr on Arch Linux. Using
    the cvs build as of yesterday the 24th of march and
    flightgear 0.9.10-pre2.

     
  • Logged In: YES
    user_id=7574

    Double check your path in the first Wizard page. Latest fgrun has a button
    to reset settings

     
  • a1270
    a1270
    2006-03-26

    Logged In: YES
    user_id=1484942

    The paths are set to the right place. Have even reinstalled
    FlightGear to /opt. Didn't help as far as i can see.

     
  • Logged In: YES
    user_id=7574

    Maybe a permission problem then. fgrun must have access to
    *-set.xml files then to the models. Before it browse the
    $FG_ROOT/Aircraft directory.

    Do the airports show up ? Even after deleting the cache or
    doing 'Refresh' ?

     
  • a1270
    a1270
    2006-03-26

    Logged In: YES
    user_id=1484942

    Airports don't show up either. All the -set.xml files are
    set to 755(-rwxr-xr-x).

     
  • Logged In: YES
    user_id=7574

    And directories ?

     
  • a1270
    a1270
    2006-03-26

    Logged In: YES
    user_id=1484942

    The directorys are set at 755 as well.

     
  • Logged In: YES
    user_id=7574

    and parent directory ? and parent of parent ?

    Please run these shell commands :
    echo $FG_ROOT
    ls -ld $FG_ROOT
    ls -ld $FG_ROOT/Aircraft
    ls -ld $FG_ROOT/Airports

    and post the result. Verify you are the owner too.

     
  • a1270
    a1270
    2006-03-26

    Logged In: YES
    user_id=1484942

    Sorry for the slow reply got busy.

    [eoden@duke ~]$ echo $FG_ROOT

    [eoden@duke ~]$ ls -ld /usr/share/FlightGear/data/
    drwxr-xr-x 25 eoden users 1080 2006-03-26 09:26
    /usr/share/FlightGear/data/
    [eoden@duke ~]$ ls -ld /usr/share/FlightGear/data/Aircraft/
    drwxr-xr-x 66 eoden users 1688 2006-03-26 09:26
    /usr/share/FlightGear/data/Aircraft/
    [eoden@duke ~]$ ls -ld /usr/share/FlightGear/data/Airports/
    drwxr-xr-x 3 eoden users 136 2006-03-26 09:26
    /usr/share/FlightGear/data/Airports/
    [eoden@duke ~]$

     
  • Logged In: YES
    user_id=7574

    which version of fltk are you using ?

     
  • Logged In: YES
    user_id=7574

    This is a problem with fltk 1.1.7. It should be configured with
    --disable-largefile. See http://fltk.org/newsgroups.php?gfltk.bugs+v:3498
    for more details

     
    • status: open --> closed