Instalation Problem

Help
sanferrera
2006-10-28
2013-05-08
  • sanferrera
    sanferrera
    2006-10-28

    I coudn't find run.sh in the tar.gz, so I am trying to run the program with java -jar startup.jar, but it seems I am having PATH problems. I get these errors:
    ...
    org.osgi.framework.BundleException: The activator org.eclipse.ui.internal.WorkbenchPlugin for bundle org.eclipse.ui.workbench is invalid
       at org.eclipse.osgi.framework.internal.core.AbstractBundle.loadBundleActivator(AbstractBundle.java:141)
       at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:968)
       at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:319)
    ....

    Anyone has had this problem before?

     
    • sanferrera
      sanferrera
      2006-10-28

      Ups... of course typing ./kelpie-planner at the prompt is the obvious answer.I am very sorry for my previous post.

      But now, I am getting this error after starting:
      Xlib: unexpected async reply (sequence 0x4a7)!

      which looks like a problem with the nvidia driver. Has anyone seen this error?

       
    • Phil
      Phil
      2007-03-16

      I am getting the same problem, and my Nvidia card works fine,

      Did you ever figure this out?

      Cheers
      Phil

       
    • When do you get this error?  At startup or when doing stuff?  Do you only get it with the world map view open?

      I personally haven't seen the error but would like to track down & fix if possible.

      What OS and Windowing environment are you using?

      Thanks
      Trevor

       
    • Also what java are you running. Pls post results of "> java -version"

      Thanks Trevor

       
    • JJChico
      JJChico
      2007-04-02

      Hi,

      I had the same problem when using the gcj java environment. It works fine after switching to sun's java machine. In Ubuntu Linux (and Debian and derivatives) you can change your default java environment by:

      $ sudo update-alternatives --config java

      Select "/usr/lib/jvm/java-1.5.0-sun/jre/bin/java" for sun's java machine. You should have installed sun-java5-jre package.

      It would be nice if fgfp would run using gcj.

      Good luck.

      jorge.

       
    • When I developed fgfp I had a secondary agenda of learning about Java 1.5 features and so for that reason  it requires java 1.5, but there is hope that it will soon run under gcj. To quote from the GJC/GCC web site: "Andrew Haley and Tom Tromey of Red Hat merged the gcj-eclipse branch to svn trunk. GCC now uses the Eclipse compiler as a front end, enabling all 1.5 language features. This merge also brings in a new, generics-enabled version of Classpath, including some new tools. All this will appear in GCC 4.3."  I'm not sure when GCC 4.3 will be commonly available, but at least it is on the way.

      Trevor