Cannot run kelpie-planner

Help
s v
2008-11-22
2013-05-08
  • s v
    s v
    2008-11-22

    Hi
    I have installed the 1.1.6 version . But when I run kelpie-planner
    it aborts with this logfile in the configuration directory.
    My system is gentoo and sun-jdk5 is installed.
    Any hints ?

    !SESSION 2008-11-21 22:26:10.308 -----------------------------------------------
    eclipse.buildId=unknown
    java.version=1.5.0_08
    java.vendor=Sun Microsystems Inc.
    BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=en_US
    Command-line arguments:  -os linux -ws gtk -arch x86 -data @user.home/fgfpWorkspace

    !ENTRY org.eclipse.osgi 4 0 2008-11-21 22:26:12.893
    !MESSAGE Application error
    !STACK 1
    org.eclipse.core.runtime.CoreException: Plug-in au.com.kelpie.rcpplanner was unable to load class au.com.kelpie.fgfp.FGFPApplication.
            at org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI.throwException(RegistryStrategyOSGI.java:180)
            at org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI.createExecutableExtension(RegistryStrategyOSGI.java:164)

     
    • Sorry to take so long to post this reply, but this forum gets so little traffic these days I often forget to look.

      The 1.1.6 version may require Java 1.6.x.  This would be my mistake for selecting some default options when building.

      I will test further and rebuild for java 1.5.x compatibility if this is actually the issue.

      Trevor

       
    • I have confirmed this version (1.1.6)  requires java 1.6. 

      If you check the log at about line 30 you should see a line like
      Caused by: java.lang.UnsupportedClassVersionError: Bad version number in .class file

      I will release an updated version that only requires java 1.5 ( which is all that is really needed ).