#108 Support FFv1.3

open
nobody
None
5
2012-09-13
2012-09-13
Peter B.
No

The current release of ffdshow-tryout (v1.2.4422) mentions "multi-threaded decoding for FFv1". Multi-threading support for FFv1 required the development of a new bitstream format for FFv1, called "FFv1.2".

Before any official release of FFv1.2, it was superseded by its successor FFv1.3.

So, if you support multi-threaded decoding of FFv1, I assume it is necessary to support FFv1.3?

Discussion

  • clsid
    clsid
    2012-09-13

    ffdshow has multi-threaded decoding, not encoding.

    Also, ffdshow is no longer under active development, so expect no changes in this regard.

     
  • Peter B.
    Peter B.
    2012-09-18

    I never assumed encoding.
    However, I thought that multithreading decoding of FFv1 would require its newer bitstream (FFv1 >= version 2).

    About ffdshow no longer being actively developed:
    ffdshow has been dead for years, but are you telling me that ffdshow-tryout is also being abandoned? :(

    Are there any alternatives?