I am still having difficulty in linking Fez Fedora objects to a custom controlled vocabulary.  I am using Fez 1.3 final with a clean install (including Fedora 2.1.1).

 

I created a new CV, and enabled it per instructions, as explained in a previous mailing list message:

___

Re: Controlled vocabularies

From: Christiaan Kortekaas <c.kortekaas@li...> - 2006-05-05 02:17 

___

 

Since I am using ‘Image MODS version 1.0’ type of document, I edited the ‘Image MODS DC Display’ for OAI DC, to use the new CV per the instructions in the message.  This allowed the new CV to show up in the record ‘enter’ and ‘edit’ forms, as well as in the ‘Browse by Subject’ pages.  Also, I am able to drill down through the three levels comprising the new CV, in both the edit popup selector and in the subject-browsing pages.  I also changed ‘Standard OAI DC Display’ and the ‘Simple OAI DC Display’, accordingly (per instructions).

 

However, just as was the case with Fez 1.3 rc3, when I go to the home page, click ‘browse by subject’, select the custom CV, and drill down to the respective sub-categories, I still only receive:

___

  List of Subject Classifications Records:  (0 results found) (0 hidden)

___

 

I am not concerned with the fact that the number of results shown is zero, because as explained in previous messages, this might just be a benign bug.  But no indication of any contained records shows up within the defined subject sub-categories, even though I know that the subject assignments were made in the custom CV.  If I temporarily assign one or more records to the existing RFCD CV, then these do show as expected, when drilling down in the subject-browse pages.

 

Also, I do not understand the reason that the RFCD input selector still remains visible in the record edit page, even though I selected instead my custom CV in the drop-down selection, when I edited the XSD display.

 

I am running Fez 1.3 rc3, with Fedora 2.1.1 on Windows XP SP2.

 

Has anyone else had this problem with 1.3 final, or is this behavior still a development matter remaining to be resolved?  Am I overlooking something major (or one or more minor operations) that causes RFCD to still show up in the edit form and that renders the custom CV unusable?

 

Frederick