Just a thought, but if the stack overflow is triggering this, have you tried modifying the memory parameters for the JVM in which the client is running?
 
The set-env script seems to specify -Xms64m -Xmx96m
 
Possibly these values are no longer appropriate for the java admin client; or increasing the stack size using -Xss might solve it (by modifying the client/bin/set-env script)?
 
(on the other hand there may be some underlying reason for the StackOverflowError that does need resolving).
 
Is there anything unusual about the object you are opening?  Can you for instance open one of the fedora system objects?
 
Steve
 
-----Original Message-----
From: Uwe Klosa [mailto:uwe.klosa@gmail.com]
Sent: 06 September 2011 13:52
To: Support and info exchange list for Fedora users.
Subject: Re: [fcrepo-user] Segmentation fault in fcrepo-client-admin-3.5.jar

I do have more information about the error:

Exception in thread "Thread-4" java.lang.StackOverflowError
        at java.lang.String.getChars(String.java:854)
        at java.lang.AbstractStringBuilder.append(AbstractStringBuilder.java:391)
        at java.lang.StringBuilder.append(StringBuilder.java:119)
        at sun.net.spi.DefaultProxySelector$3.run(DefaultProxySelector.java:218)
        at sun.net.spi.DefaultProxySelector.select(DefaultProxySelector.java:201)
        at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:358)
        at java.net.Socket.connect(Socket.java:529)
        at sun.reflect.GeneratedMethodAccessor15.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at org.apache.axis.components.net.DefaultSocketFactory.create(DefaultSocketFactory.java:153)
        at org.apache.axis.components.net.DefaultSocketFactory.create(DefaultSocketFactory.java:120)
        at org.apache.axis.transport.http.HTTPSender.getSocket(HTTPSender.java:191)
        at org.apache.axis.transport.http.HTTPSender.writeToSocket(HTTPSender.java:404)
        at org.apache.axis.transport.http.HTTPSender.invoke(HTTPSender.java:138)
        at org.apache.axis.transport.http.HTTPSender.readFromSocket(HTTPSender.java:727)
        at org.apache.axis.transport.http.HTTPSender.invoke(HTTPSender.java:144)
        at org.apache.axis.transport.http.HTTPSender.readFromSocket(HTTPSender.java:727)
        at org.apache.axis.transport.http.HTTPSender.invoke(HTTPSender.java:144)
.....
        at org.apache.axis.strategies.InvocationStrategy.visit(InvocationStrategy.java:32)
        at org.apache.axis.SimpleChain.doVisiting(SimpleChain.java:118)
        at org.apache.axis.SimpleChain.invoke(SimpleChain.java:83)
        at org.apache.axis.client.AxisClient.invoke(AxisClient.java:165)
        at org.apache.axis.client.Call.invokeEngine(Call.java:2784)
        at org.apache.axis.client.Call.invoke(Call.java:2767)
        at org.apache.axis.client.Call.invoke(Call.java:2443)
        at org.apache.axis.client.Call.invoke(Call.java:2366)
        at org.apache.axis.client.Call.invoke(Call.java:1812)
        at org.fcrepo.server.management.FedoraAPIMBindingSOAPHTTPStub.getDatastreams(FedoraAPIMBindingSOAPHTTPStub.java:1000)
        at org.fcrepo.client.APIMStubWrapper$13.construct(APIMStubWrapper.java:1151)
        at org.fcrepo.client.SwingWorker$2.run(SwingWorker.java:131)
        at java.lang.Thread.run(Thread.java:662)

/Uwe


On 6 September 2011 09:09, Uwe Klosa <uwe.klosa@gmail.com> wrote:
Yes, I started the java admin client. I did a search and then I double clicked on of the search results. You can see in the status field that the client is reading data from fedora. The segmantation fault occurs just before the new window showing the objects content appears. I tried that with different types of objects and on different machines with Ubuntu. On all machines the same error occurred. I did not test it on Windows or OSX.


On 5 September 2011 22:54, Aaron Birkland <birkland@cs.cornell.edu> wrote:
Hi Uwe,

> I'm getting a segmentation fault every time I try to open an object
> with the fcrepo administrator client.

I assume you used the java-based administrator client, and that the
segfault occurred within the VM in which the client was running.  Is
that correct?

I was able to successfully open an object on my machine.  64-bit, Fedora
15:

java version "1.6.0_26"
Java(TM) SE Runtime Environment (build 1.6.0_26-b03)
Java HotSpot(TM) 64-Bit Server VM (build 20.1-b02, mixed mode)

Linux 2.6.40.3-0.fc15.x86_64 #1 SMP Tue Aug 16 04:10:59 UTC 2011 x86_64
x86_64 x86_64 GNU/Linux

I did not see a segfault.  Can you list the exact steps you took to
reproduce this problem?

  -Aaron




------------------------------------------------------------------------------
Special Offer -- Download ArcSight Logger for FREE!
Finally, a world-class log management solution at an even better
price-free! And you'll get a free "Love Thy Logs" t-shirt when you
download Logger. Secure your free ArcSight Logger TODAY!
http://p.sf.net/sfu/arcsisghtdev2dev
_______________________________________________
Fedora-commons-users mailing list
Fedora-commons-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/fedora-commons-users