Thanks Mike!

But it sounds even worse. I got no fedora-rebuild.log after I run fedora-rebuilder.bat.

Hao

On Tue, Jun 9, 2009 at 10:11 AM, Durbin, Michael R <midurbin@indiana.edu> wrote:

The instructions are correct, and Iím pretty sure you donít need to ingest the generated content model objects before rebuilding.

As for the error, often a more helpful and complete error message is contained in the /FEDORA_HOME/server/logs/fedora-rebuild.log (sometimes the true cause occurs before the error that is printed out from the rebuilder).

-Mike

From: Hao Jiang [mailto:hjiang@ist.psu.edu]
Sent: Tuesday, June 09, 2009 8:15 AM
To: fedora-commons-users@lists.sourceforge.net
Subject: [Fedora-commons-users] problem with upgrade from fedora221 to fedora32 (fedora-rebuilder)

Hi there,

I recently tried to move from version 2.2.1 to 3.2, and followed the upgrade guide at http://www.fedora.info/confluence/display/FCR30/Upgrading+from+2.x. It seems work fine with those utility tools like analyzer, generator and transformer. However, when I followed the guide to run fedora-rebuilder.bat. It looks doesn't work.

I installed a new fedora32 with an existing tomcat, and new database called fedora32 on an existing mysql server. I copied old data (data folder) from fedora2.2.1 home to the newly installed fedora32 data folder, and then run the utility tools. those analytical files are generated as described.


Here is the exception:

-----------------------------------------------------------------------------------------------
C:\Fedora32\server\bin>fedora-rebuild.bat

†††††††††††††††††††††† Fedora Rebuild Utility
†††††††††††††††††††† ..........................

WARNING: Live rebuilds are not currently supported.
†††††††† Make sure your server is stopped before continuing.

Server directory is C:\Fedora32\server

---------------------------------------------------------------------

What do you want to do?

† 1) Rebuild the Resource Index.
† 2) Rebuild SQL database.
† 3) Exit

Enter (1-3) --> 2

Rebuild SQL database.

Start rebuilding with the above options?

† 1) Yes
† 2) No, let me re-enter the options.
† 3) No, exit.

Enter (1-3) --> 1
†INFO [main] (ServerUtility.java:107) - Getting URL: http://localhost:80/fedora/
describe

Rebuilding...
Error shutting down RebuildServer:
java.lang.NullPointerException
††††††† at fedora.server.utilities.rebuild.SQLRebuilder.finish(SQLRebuilder.java
:628)
††††††† at fedora.server.utilities.rebuild.Rebuild.<init>(Rebuild.java:116)
††††††† at fedora.server.utilities.rebuild.Rebuild.main(Rebuild.java:367)
Error: The specified module class "fedora.server.messaging.MessagingModule" coul
d not be found.

fedora.server.errors.ModuleInitializationException: The specified module class "
fedora.server.messaging.MessagingModule" could not be found.
††††††† at fedora.server.Server.<init>(Server.java:555)
††††††† at fedora.server.utilities.rebuild.RebuildServer.<init>(RebuildServer.ja
va:36)
††††††† at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)

††††††† at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstruct
orAccessorImpl.java:39)
††††††† at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingC
onstructorAccessorImpl.java:27)
††††††† at java.lang.reflect.Constructor.newInstance(Constructor.java:494)
††††††† at fedora.server.utilities.rebuild.RebuildServer.getRebuildInstance(Rebu
ildServer.java:114)
††††††† at fedora.server.utilities.rebuild.SQLRebuilder.start(SQLRebuilder.java:
110)
††††††† at fedora.server.utilities.rebuild.Rebuild.<init>(Rebuild.java:92)
††††††† at fedora.server.utilities.rebuild.Rebuild.main(Rebuild.java:367)

C:\Fedora32\server\bin>start.

C:\Fedora32\server\bin>
---------------------------------------------------------------------------------------------------------------

Any thought? Should I ingest those objects first? but this step follows fedora-rebuilder.bat as in the guide.

Thanks a lot,
Hao

--
Jiang, Hao
PhD Candidate
CSCL Lab, HCI Center
Penn State College of Information Sciences and Technology
http://cscl.ist.psu.edu/public/users/hjiang


------------------------------------------------------------------------------
Crystal Reports - New Free Runtime and 30 Day Trial
Check out the new simplified licensing option that enables unlimited
royalty-free distribution of the report engine for externally facing
server and web deployment.
http://p.sf.net/sfu/businessobjects
_______________________________________________
Fedora-commons-users mailing list
Fedora-commons-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/fedora-commons-users