It looks like that version of Java reached its end of life a few years back. 




I’m not sure what the minimum version is to run Fedora, but this might be affecting your install.  Could be worth upgrading.


What flavor and version of Linux are you running?  An updated version might be in the repositories.


From: Jeffrey Applegate []
Sent: Thursday, March 18, 2010 4:23 PM
To: Chris Wilper
Subject: Re: [Fedora-commons-users] Fedora commons install error v3.3



Thanks for responding. I was attempting to be patient. Obviously this is definitely a unique issue. I tested the account via the MySQL command line utility and it works. I am running Java version 1.4.2.

Jeff Applegate
ASRC Management Services
Contracted To:
US Geological Survey
Fort Collins Science Center
2150 Centre Ave., Bldg C
Fort Collins, CO 80526
Phone: 970-226-9178
Fax: 970-226-9230


Chris Wilper <>


Jeffrey Applegate <>



03/18/2010 02:14 PM


Re: [Fedora-commons-users] Fedora commons install error v3.3

Sent by:


Hi Jeff,

Hmmm, I was hoping this would ring a bell with someone else out there.
I am still perplexed on why this isn't working for you.

Have you tried logging into this MySQL instance with any other utility
(e.g. via the mysql command line or admin utility) with the
username/password you're providing here?  Just to verify it's running
and it is indeed possible to log in to it at all.

Also, which version of Java are you running (check with java --version)

- Chris

On Thu, Mar 18, 2010 at 3:28 PM, Jeffrey Applegate <> wrote:
> I don't have a stack trace. The error only states "Unexpected exception
> encountered during query." Then it goes back and  I am using the default
> MySQL driver that is bundled with the installer. I have created two
> databases, one as the default and one called fedora_commons. I have
> attempted to use the default JDBC url and one that I type in manually. Both
> are getting the same exact error message. I have attempted to use two
> different users just incase one was bad. Here are the steps that I am going
> through:
> Here are the steps:
> 1 - custom
> 2 - /usr/local/webapp
> 3- add a password
> 4 - leave at default (local host)
> 5 - leave at default (
> 6 - leave at default (false)
> 7 - leave at default (true)
> 8 - leave at default (false)
> 9 - leave at default (true)
> 10 - existingTomcat
> 11 - /usr/local/tomcat
> 12 - leave at default (8080)
> 13 - leave at default (8005)
> 14 - leave at default (8443)
> 15 - type in default
> 16 - leave as default (changeit)
> 17 - leave as default (JKS)
> 18 - mysql
> 19 - leave as default (included JDBC driver)
> 20 - fedoraadmin
> 21 - insert password that was created
> 22 - I have tried using both of the following. I created the second database
> and the install created the first.
>       a.
> jdbc:mysql://localhost/fedora3?useUnicode=true&amp;characterEncoding=UTF-8&amp;autoReconnect=true
>       b.
> jdbc:mysql://localhost/fedora_commons?useUnicode=true&amp;characterEncoding=UTF-8&amp;autoReconnect=true
> 23 - leave as default (com.mysql.jdbc.Driver)
> 24 - receive error - Unexpected exception encountered during query.
> 25 - install starts back to requesting a JDBC driver for MySQL and steps
> 19-23 become a never ending loop with the error message always coming up.