Rich

 

Don’t assume that it’s just you.  This sounds rather familiar and we’ve been wondering if it was *us*.  Are you trying this with the Fedora Java admin client (ingest object(s) from repository)?  If so – exactly what error message do you get?  What version of Fedora are you using?

 

Richard

___________________________________________________________________

 

Richard Green

Consultant to Library & Learning Innovation, University of Hull

managing the History DMP and Hydra (Hull) Projects

 

http://hydra.hull.ac.uk

http://hydrangeainhull.wordpress.com

http://projecthydra.org

http://historydmp.wordpress.com

 

 

 

From: Burgis, Richard [mailto:burgisri@ais.msu.edu]
Sent: 29 November 2011 4:04 PM
To: Support and info exchange list for Fedora users.
Subject: [fcrepo-user] Ingest Question

 

I’m moving a test repository and trying various methods to get it to work.

 

For objects with  embedded content (X), I have no problem ingesting from the source repository. But when I try ingesting objects with Managed content (M), I get errors saying that the managed content cannot be found.

 

I tried exporting the objects and ingesting the exported objects, but I get the same result.

 

I modified the contentLocation  to use file URLs pointing to the location of the content in the file system. This time the ingest succeeded, but I got errors (500?) when I tried to edit or view the content. I got the same error when I attempted to re-import it via the Admin program. I was finally able to get the import to work after purging the items.

 

This seems unreasonable as a process, so I would assume that I am missing something critical.

 

Any suggestions?

Thanks

Rich