Howdy all,

I would like to be able to attach a DC datastream to a new object being created in fedora either when the initial metadata is added or in a separate operation. However, I'm having no success.  For test purposes, I tried dropping the following into a FOXML file:

<foxml:datastream ID="DC" STATE="A" CONTROL_GROUP="X"  VERSIONABLE="true">
    <foxml:datastreamVersion ID="DC.0" LABEL="Dublin Core Record"    MIMETYPE="text/xml">
    <foxml:contentLocation TYPE="URL"   REF="http://allianceharvest.uoregon.edu/cdm/oai.xml" />
 </foxml:datastreamVersion>

No luck, though that syntax worked fine for . I've also tried attaching it directly via

 curl -v -u fedoraAdmin:***** -X PUT "dsLocation=http://allianceharvest.uoregon.edu/cdm/oai.xml" http://127.0.0.1:8080/fedora/objects/demo:1003/datastreams/DC

without success. It's reporting back that there's a new version but the copy of the DC in the file if I view object XML in the interface is the same thing repeated over and over and not what I tried to add.

However, if I try to inhale the metadata from a URL using the admin interface, it works every time. I know I'm missing something stupid and simple, but I can't see what it is to save my life. Any pointers would be appreciated. Thanks,

kyle
--
----------------------------------------------------------
Kyle Banerjee
Digital Services Program Manager
Orbis Cascade Alliance 
banerjek@uoregon.edu / 503.877.9773