I think that's good to point out, Jeremy.  There are a variety of ways (depending on distro) to switch the version that's used in the path by all users by default, and depending on how your system is administered, this may or may not cause problems with services that depend on a specific version.

My preference when working on any un*x is to use the package manager to install Sun's jdk if possible, but not to depend on what's in the PATH by default to pick up the right java version when running an app that needs java.  Instead, I think it's better to ensure that when the application is started, the JAVA_HOME environment variable points to the location of the specific jdk I want to use (this will vary...I don't know where it is normally installed for Red Hat 5, but I bet google does), and that the PATH environment variable has $JAVA_HOME/bin as one of the first entries.

For example, if you plan to start/stop Fedora at the command line as the 'fedora' os user who uses bash, you might put something like the following in /home/fedora/.bashrc (taken directly from mine on an Ubuntu machine):

# User specific aliases and functions
export JAVA_HOME=/usr/local/java/jdk1.6.0_11
export PATH=$JAVA_HOME/bin:$PATH
export FEDORA_HOME=/usr/local/fedora-3.3
export CATALINA_HOME=$FEDORA_HOME/tomcat

When you reach a point where you want to start Fedora (actually, tomcat) automatically when the machine boots, I'd advise doing something similar in your associated init.d script.

- Chris

On Thu, Mar 18, 2010 at 4:50 PM, Gottwig, Jeremy M. (GSFC-272.0)[ZIMMERMAN & ASSOC.] <jeremy.m.gottwig@nasa.gov> wrote:

Of course, before I get anyone into trouble, I should note that upgrading Java can sometimes cause problems with legacy software that depends on the existing version.

 

From: Gottwig, Jeremy M. (GSFC-272.0)[ZIMMERMAN & ASSOC.] [mailto:jeremy.m.gottwig@nasa.gov]
Sent: Thursday, March 18, 2010 4:42 PM
To: fedora-commons-users@lists.sourceforge.net


Subject: Re: [Fedora-commons-users] Fedora commons install error v3.3

 

It looks like that version of Java reached its end of life a few years back. 

 

See:

 

http://java.sun.com/j2se/1.4.2/download.html

 

I’m not sure what the minimum version is to run Fedora, but this might be affecting your install.  Could be worth upgrading.

 

What flavor and version of Linux are you running?  An updated version might be in the repositories.

 

From: Jeffrey Applegate [mailto:applegatej@usgs.gov]
Sent: Thursday, March 18, 2010 4:23 PM
To: Chris Wilper
Cc: cwilper@gmail.com; fedora-commons-users@lists.sourceforge.net
Subject: Re: [Fedora-commons-users] Fedora commons install error v3.3

 

Chris,

Thanks for responding. I was attempting to be patient. Obviously this is definitely a unique issue. I tested the account via the MySQL command line utility and it works. I am running Java version 1.4.2.

Jeff Applegate
ASRC Management Services
Contracted To:
US Geological Survey
Fort Collins Science Center
2150 Centre Ave., Bldg C
Fort Collins, CO 80526
Phone: 970-226-9178
Fax: 970-226-9230
Email: applegatej@usgs.gov

From:

Chris Wilper <cwilper@duraspace.org>

To:

Jeffrey Applegate <applegatej@usgs.gov>

Cc:

fedora-commons-users@lists.sourceforge.net

Date:

03/18/2010 02:14 PM

Subject:

Re: [Fedora-commons-users] Fedora commons install error v3.3

Sent by:

cwilper@gmail.com

 





Hi Jeff,

Hmmm, I was hoping this would ring a bell with someone else out there.
I am still perplexed on why this isn't working for you.

Have you tried logging into this MySQL instance with any other utility
(e.g. via the mysql command line or admin utility) with the
username/password you're providing here?  Just to verify it's running
and it is indeed possible to log in to it at all.

Also, which version of Java are you running (check with java --version)

- Chris

On Thu, Mar 18, 2010 at 3:28 PM, Jeffrey Applegate <applegatej@usgs.gov> wrote:
> I don't have a stack trace. The error only states "Unexpected exception
> encountered during query." Then it goes back and  I am using the default
> MySQL driver that is bundled with the installer. I have created two
> databases, one as the default and one called fedora_commons. I have
> attempted to use the default JDBC url and one that I type in manually. Both
> are getting the same exact error message. I have attempted to use two
> different users just incase one was bad. Here are the steps that I am going
> through:
>
> Here are the steps:
> 1 - custom
> 2 - /usr/local/webapp
> 3- add a password
> 4 - leave at default (local host)
> 5 - leave at default (
www.example.com/fedora)
> 6 - leave at default (false)
> 7 - leave at default (true)
> 8 - leave at default (false)
> 9 - leave at default (true)
> 10 - existingTomcat
> 11 - /usr/local/tomcat
> 12 - leave at default (8080)
> 13 - leave at default (8005)
> 14 - leave at default (8443)
> 15 - type in default
> 16 - leave as default (changeit)
> 17 - leave as default (JKS)
> 18 - mysql
> 19 - leave as default (included JDBC driver)
> 20 - fedoraadmin
> 21 - insert password that was created
> 22 - I have tried using both of the following. I created the second database
> and the install created the first.
>       a.
> jdbc:mysql://localhost/fedora3?useUnicode=true&amp;characterEncoding=UTF-8&amp;autoReconnect=true
>       b.
> jdbc:mysql://localhost/fedora_commons?useUnicode=true&amp;characterEncoding=UTF-8&amp;autoReconnect=true
> 23 - leave as default (com.mysql.jdbc.Driver)
> 24 - receive error - Unexpected exception encountered during query.
> 25 - install starts back to requesting a JDBC driver for MySQL and steps
> 19-23 become a never ending loop with the error message always coming up.


------------------------------------------------------------------------------
Download Intel&#174; Parallel Studio Eval
Try the new software tools for yourself. Speed compiling, find bugs
proactively, and fine-tune applications for parallel performance.
See why Intel Parallel Studio got high marks during beta.
http://p.sf.net/sfu/intel-sw-dev
_______________________________________________
Fedora-commons-users mailing list
Fedora-commons-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/fedora-commons-users