Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#1 make it compile and work with gtk2

0.9
closed
nobody
5
2004-03-22
2003-02-01
Jens Georg
No

This patch enables fbpanel to be compiled and used with
gtk2. some minor graphics update glitches are still in
the code, but i think it's a pretty good start

Discussion

1 2 > >> (Page 1 of 2)
    • labels: --> new functionality
    • milestone: --> 0.9
     
  • Ohad Lutzky
    Ohad Lutzky
    2003-10-06

    Logged In: YES
    user_id=520766

    Sounds good, but more like a feature request ;)

     
  • Jens Georg
    Jens Georg
    2003-10-06

    Logged In: YES
    user_id=244158

    Oh sh*t, I will attach the patch as soon as I have fixed my PC's

     
  • Ohad Lutzky
    Ohad Lutzky
    2003-10-13

    Logged In: YES
    user_id=520766

    Aw man, I really want this! :(

     
  • Jens Georg
    Jens Georg
    2003-10-15

    Logged In: YES
    user_id=244158

    Ok, here it is. I tried to port it to fbpanel-2.2. This has only partially
    succeeded; the code is glib-2.0/gdk-2.0 clean, which means it compiles
    with -DG_DISABLE_DEPRECATED and
    -DGDK_DISABLE_DEPRECATED, but not with
    -DGTK_DISABLE_DEPRECATED (see Makefile). This is mostly
    because of gtk[hv]tbar.c (I'm not familiar with widget programming,
    sorry), but there are 3 other places where I could not find a
    replacement in gtk-2.0; in these places I added #warning's

     
  • Jens Georg
    Jens Georg
    2003-10-15

     
    Attachments
  • Jens Georg
    Jens Georg
    2003-10-15

    Logged In: YES
    user_id=244158

    Oh, I forgot - it compiles fine ;)

     
  • Jens Georg
    Jens Georg
    2003-10-15

     
    Attachments
  • Logged In: NO

    Hmmm... Could we get a screeny? I really want this... Also,
    I'm not so sure how to use it with fbPanel. How do I patch it?

     
  • Jens Georg
    Jens Georg
    2003-12-08

    Logged In: YES
    user_id=244158

    Screeny: Scroll down ;)

    cd fbpanel-2.2

    patch -p1 <fbpanel-2.2.diff

     
1 2 > >> (Page 1 of 2)