cmake error: CPU you selected does not suppor

2011-09-02
2012-12-07
  • Mehmood Khan
    Mehmood Khan
    2011-09-02

    130-229-49-49:build-branch-1 malagori$ cmake -DBUILD_DOCBOOK=ON -DCMAKE_INSTALL_PREFIX=/install-branch-1  /Users/malagori/Documents/Academic/project/svn/fastphylo/branches/speedups && make && make install
    - The C compiler identification is GNU
    - The CXX compiler identification is GNU
    - Checking whether C compiler has -isysroot
    - Checking whether C compiler has -isysroot - yes
    - Checking whether C compiler supports OSX deployment target flag
    - Checking whether C compiler supports OSX deployment target flag - yes
    - Check for working C compiler: /usr/bin/gcc
    - Check for working C compiler: /usr/bin/gcc - works
    - Detecting C compiler ABI info
    - Detecting C compiler ABI info - done
    - Checking whether CXX compiler has -isysroot
    - Checking whether CXX compiler has -isysroot - yes
    - Checking whether CXX compiler supports OSX deployment target flag
    - Checking whether CXX compiler supports OSX deployment target flag - yes
    - Check for working CXX compiler: /usr/bin/c++
    - Check for working CXX compiler: /usr/bin/c++ - works
    - Detecting CXX compiler ABI info
    - Detecting CXX compiler ABI info - done
    - Found LibXml2: /opt/local/lib/libxml2.dylib
    - Configuring done
    - Generating done
    - Build files have been written to: /Users/malagori/Documents/Academic/project/project-gf/workplace-gf/build-branch-1
    Scanning dependencies of target fastphylo
    Building CXX object src/c++/CMakeFiles/fastphylo.dir/BitVector.cpp.o
    /Users/malagori/Documents/Academic/project/svn/fastphylo/branches/speedups/src/c++/BitVector.cpp:1: error: CPU you selected does not support x86-64 instruction set
    /Users/malagori/Documents/Academic/project/svn/fastphylo/branches/speedups/src/c++/BitVector.cpp:1: error: CPU you selected does not support x86-64 instruction set
    make: ***  Error 1
    make: ***  Error 2
    make: ***  Error 2

     
  • Mehmood Khan
    Mehmood Khan
    2011-09-02

    comment the following lines in …/src/CMakelist.txt file:

    #SET(ARCH_FLAGS "" )
    #SET(ARCH_FLAGS "-march=pentium4 -msse2" ) 

    It will work :)