Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

How to stop the debugger from stepping into F

Help
2008-10-09
2013-05-23
  • manilu georian
    manilu georian
    2008-10-09

    How to stop the debugger from stepping into FastMM's source code?

    It is really annoying when I want to debug my program and the debugger step into FastMM4.pas

    I am using FastMM4 and Delphi 7.

    Thanks

     
    • Muetze1
      Muetze1
      2008-10-09

      Generally you can use the debugger feature SHIFT-F8 to get back out and step over that code.

      HTH
      Muetze1

       
    • Hi fedra,

      You can enabled the "NoDebugInfo" option. That will prevent the debugger from stepping into the FastMM source.

      Regards,
      Pierre

       
    • manilu georian
      manilu georian
      2008-10-10

      In FastMM4Options.inc the NoDebugInfo is set like this:

      {.$define NoDebugInfo}

      Which I suppose it means 'disabled'. Of course I deleted the DCU files, recompiled, but the debugger still steps into FastMM.
      I also tried to remove FastMM folder from 'Library Path'.
      In this case is even worst: the debugger cannot find the FASTMM PAS files so it stops and ask me where are the files.

       
    • manilu georian
      manilu georian
      2008-10-10

      "Generally you can use the debugger feature SHIFT-F8"

      While in FastMM4.pas, this will only bring the CPU window.

       
    • manilu georian
      manilu georian
      2008-10-10

      OH SORRY!!!!

      I need to remove the dot. Today I wake up brainless. :)

      {$define NoDebugInfo}