FSX crashes after starting FTNoIR

  • I've had this problem with another app that uses SimConnect, and I'm hoping you know more than the developer of the other app.

    I am running FSX + Acceleration on a 64-bit HP desktop (Intel Quad core, Q6700 @ 2.66 Ghz, 6 GB RAM) and Vista SP2.  I've installed FTNOIR 1.6, and selected the Simconnect.ini profile and SimConnect protocol.  When I start the program without starting FSX, my webcam comes on, detects my face and shows the yellow lines around my eyes/glasses down to my chin, and the x/y/z and rotation parameters change with my head movements.  No problem there.  The problem comes when i start FSX AND THEN start FTNOIR.  FSX freezes, then crashes and the OS offers to restart it before I can configure a Free Flight.  My SimConnect settings are:

    Global, IPv4, port 500, (desktop IP from DHCP router), 64 clients
    Global, IPv4, port 6811,, 64 clients
    local, auto protocol
    Local, IPv4, port 8077,, 64 clients 

    Are these the right Simconnect settings for FaceTrackNoIR?  Or is there something else I should be looking at to solve this.  If I don't specify any of the above, FTNOIR works fine and so does FSX, but when I start a flight and move my head, nothing happens in the sim. 

    (btw, the other app I had problems with (FsMovMap) actually worked well for quite awhile then also started crashing FSX.)


  • sf4JC

    I'm curious, why would anyone want to change SimConnect.  I must be out of the loop, cause I've never heard of anyone ever changing SimConnect, and I've been using FSX since it's beginning, though the last year has been hit and miss.


  • Scott,

    First let me say I'm no expert at this, but in researching how to fix my problem I ran across some articles and forum postings about getting the SimConnect SDK to work with add-on software by configuring the TCP/IP address and ports.  At first I couldn't even find the Simconnect.cfg and Simconnect.xml files on my computer, but then found them and downloaded them into the recommended directories.  I even found a little app that someone had written that changes the XML file. 

    I had the other add-on I referenced, FsMovMap, working for several weeks then suddenly stop working and I thought that it might be because some settings somewhere had been altered.  Using FaceTrackNoIR exhibits exactly the same symptoms when I try to connect to FSX, and when I realized that it also uses SimConnect I thought that maybe that's what was "broken".  So after completely uninstalling and reinstalling FSX and seeing the same problem, I went back to investigating SimConnect. 

    I'm down to grasping at straws, and am hoping there's an "expert" (i.e. anyone who knows more about this than I do) out there that can help me.


  • Wim Vriend
    Wim Vriend

    Hi mdt,

    I don't really see the connection.

    The SimConnect protocol of FaceTrackNoIR does not require or use any ports, so the changes you made should have no effect. Of course I don't know very much about the inner workings of SimConnect: for me it's just a bunch of API-calls I implemented. Maybe some guys at the AVSIM forum can help you?