OS 6 and 7 hangs on "connecting to...

Anonymous
2011-11-08
2013-05-02

  • Anonymous
    2011-11-08

    Hi, i want to ask… i made application for BB OS 5 and above.. and i am using facebook sdk 8.24.. i've modified few code in Facebook SDK, so its work perfectly on BB OS 5, but when i try in OS 6 and 7 its always hangs when "connecting to facebook" loading appear, and never show login form…

    anyone can help me? i dont know whats wrong with my code, since its work perfectly on OS 5

     

  • Anonymous
    2011-11-08

    this i found strange… when i debugging in OS 5 and OS 6… every steps are almost the same.. except for 1:

    When OS 5 try to access

    [INFO] LoggableConnectionFactory (TCP Cellular): http://m.facebook.com/login.php?app_id=114029790442&cancel=http%3A%2F%2Fwww.facebook.com%2Fconnect%2Flogin_success.html%3Ferror_reason%3Duser_denied%26error%3Daccess_denied%26error_description%3DThe%2Buser%2Bdenied%2Byour%2Brequest.&fbconnect=1&next=https%3A%2F%2Fm.facebook.com%2Fdialog%2Fpermissions.request%3F_path%3Dpermissions.request%26app_id%3D114029790442%26redirect_uri%3Dhttp%253A%252F%252Fwww.facebook.com%252Fconnect%252Flogin_success.html%26display%3Dwap%26response_type%3Dtoken%26fbconnect%3D1%26perms%3Dpublish_stream%252Cread_stream%252Cuser_about_me%252Cemail%252Cuser_events%252Coffline_access%26from_login%3D1&rcount=1&_rdr;deviceside=true
    

    but in OS 6 i found:

    http://www.facebook.com/mobile/reliability.php?edata=AZPzpIbpqFqpKNYT3t2oWzlPWttHV2mcqIRVQnL0Plh5XjjlLnU2fqZxC0NusGwhyQPegYPjWdz6HeOzqLkrZpCuzJ-dV4lL10XDAJqW60VT9pBR6y3lpgl2mztREpEpY1xHL3BkhGYewcbqkb8n8e-uyUALqOGS7gepruliY1dm0UJGdp58svs5WPNQr9N4RGaLD60bOv-UqW51wRqXWh6W9u9eC-b10zYpMBCRJeKvlYZnvq-WExhVX3yUWW0IamM5eIMDopcOSMfTxEaB75qUqzgpzKtHDVUwYJWwY-KB2j6rMpBXwOj5siFZE1GjzkSwTI9atYzTAan3hgfna76YcAocF_46KMCsMqYe7lBYfmeGDe4IpRdxvGdT7a1YCcNpJ5NrAAX4oZvLqTsH-ArG_CIzXSqKNjcNv01Cj_xoW0alOYA2GDxfRQj-nKRDa05BmArJC21GQtNbxyTqDGO_3hJmfv5wqCSaFtwLYGieCOqwV6SNTdSwPBY8Q24xztihffiDocREfoNZLxxh5e3FUH7ygc6RYP-M3J1NhIwZ5ISvBA1goBeT3hLx8McJRd0ljO5A3UNxPzvTvgBfgQjMVNZwu8Ow4nvYqiF-bSSPbHaG1u_GTx48kRAGDiN4fotoIYfPS9lFsFJZvFA1GTq6XB6ESEJtRgedy5ICGU4tAy4_Hor2QekZQWW3gkBrt03oMkHgY-_HvlQZ8nv-qz5ef8vzQB9s5UUlDxxnSUco4vbY73o-9uGuKmJ7rWMHddKnABv7h0sFSdKrxi9frCxjjpncKtt4VDPE4i17eLYQxUGA9Xq5BUvniHXYHGtw3eRmBXn816SR0_MoRz0y__2hcZjlcswAJuojxKWqEfg4L0rRLLmWooRWTU5eAuzryxQ8mKbec8cgS__c-NqMvmzSQ_XYdjB3tBB4EfXT1HWFXiYKPEEf5qUuzrkYyejxwxiVHuwOr6VelAkX5ybgmnaD7rLrfbw7ILYpXt4_g0sXw515i-Gwsg5qjO_H7w-uuKWd3VRWkAjwts4Wr_I8kc2IaJfL03Mjd_594hQ1D2idFsawX8Bgk5gsvVqqSqWT6g-_2Ar846WeoWhJgVeSET_OXcjwp4qMmJUKZtSlaqLgAs8aip0dP8upm4axjZnuK6WFH8n8PoqviIR3MzUS7uF4hkQTiVE1Jd_gtC5blYo1xEiCHZwG2p3rVQpikbDRIdr8ePJO_eS26-e21Thz4L0SQezq4Q1WKxWelaylIWVdb2YJ4c3mMqMhTPyMl_vA_ByEuJVvJUxHT8-NIl3XWzYuHwNQ7bcsQ9cJx4f5pAYZCCAvZAH1Uzu5i3RVGDVsXYYn-XU9bXE_X9SEQIjj-PhmMERXCAqAx366ZrZcLD_fPG2hkduVUsMvv24Q2QNm8Xc;deviceside=true
    

    why they are different if i use the same code??

     
  • Danish
    Danish
    2012-01-03

    Hello,

    I am facing the same problem. Can anybody suggest whats the actual cause we are facing?

    Thanks

     
  • Christopher
    Christopher
    2012-01-29

    I have deploy an App on OS 6 and I have no problems.

    Do you use a Sync or Async connection? On OS 6 I have errors with the Sync Connection.

    Show me your code and the point where Facebook Connection appears