Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#23 ezquake doesn't launch under Mac OS 10.5.4

closed
Zwoch
5
2009-08-30
2008-09-11
Anonymous
No

installed via latest nQuake using the stub-hub mirror.
attempting to run ezQuake-gl.app throws:
----------------------------------------
Process: EZQuake-GL [5663]
Path: /Applications/nQuake/EZQuake-GL.app/Contents/MacOS/EZQuake-GL
Identifier: net.sf.ezquakegl
Version: ??? (???)
Code Type: X86 (Native)
Parent Process: launchd [85]

Date/Time: 2008-09-11 19:15:42.555 +0100
OS Version: Mac OS X 10.5.4 (9E17)
Report Version: 6

Exception Type: EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000
Crashed Thread: 0

Dyld Error Message:
Library not loaded: /opt/local/lib/libjpeg.62.dylib
Referenced from: /Applications/nQuake/EZQuake-GL.app/Contents/MacOS/EZQuake-GL
Reason: image not found
----------------------------------------
on a recent mac:
Model: MacBook3,1, BootROM MB31.008E.B02, 2 processors, Intel Core 2 Duo, 2 GHz, 4 GB
Graphics: kHW_IntelGMA965Item, GMA X3100, spdisplays_builtin, 144 MB

Discussion

  • This also occurs on 10.4.11 on an older mac.

    Host Name: <LOLNO!>
    Date/Time: 2008-09-15 05:35:58.634 -0500
    OS Version: 10.4.11 (Build 8S165)
    Report Version: 4

    Command: EZQuake-GL
    Path: /Applications/nQuake/EZQuake-GL.app/Contents/MacOS/EZQuake-GL
    Parent: WindowServer [236]

    Version: 1517 (1.1)

    PID: 7309
    Thread: Unknown

    Link (dyld) error:

    Library not loaded: /opt/local/lib/libjpeg.62.dylib
    Referenced from: /Applications/nQuake/EZQuake-GL.app/Contents/MacOS/EZQuake-GL
    Reason: image not found

     
  • Don't expect the ezQuake developers too look here, their stuff on sf.net seems to be a big mess (as what I see/have seen), the best is probaly to ask on quakeworld.nu or their IRC-channel.

     
  • JohnNy_cz
    JohnNy_cz
    2009-08-30

    Hello, we are still interested in Mac OS X related feedback, please keep us informed. Sorry for the big delay. Mac developer will have a look at this report and have his say.

     
  • JohnNy_cz
    JohnNy_cz
    2009-08-30

    • assigned_to: nobody --> zwoch
     
  • Zwoch
    Zwoch
    2009-08-30

    Hm well.. we haven't responded to this bug for a long time. On the other hand one of the reports indicate version 1517. This is like super old. Even for the reported date. This bug basically says that the dynamically linked jpeg library could not be loaded. From my knowledge this was a bug in 1517. I think was fixed in recent 1.8.x 1.9.x builds. There might be a version where we missed that bu all recent versions are fine. Upcoming 2.0 will be statically linked so we should not see those kinds of reports in the future. Could the nQuake mirror be out of date?!

     
  • Zwoch
    Zwoch
    2009-08-30

    • status: open --> closed