Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#538 GLX client, sound doesn't work in 2.2 alpha

3.0
closed
nobody
None
6
2014-01-02
2013-11-20
Faustov
No

Linux GLX client alpha 2.2 build from september13 (says 3.0 alpha but is 2.2 alpha), the sound does not work, error message is "failed to initialize alsa". Works fine in 2.1 though.

Discussion

  • dimmman
    dimmman
    2013-12-03

    • Group: 2.1 --> 3.0
      Your version is actually a 2.2 alpha. It's the same sound code as 2.1 so I'm betting the problem is within library version. Please try to compile the sources and see if it helps, let me know if it works.

    ezQuake 3.0 will be using a unified SDL2 sound backend.

     
    Last edit: dimmman 2013-12-03
  • dimmman
    dimmman
    2014-01-02

    • status: open --> closed-invalid
     
  • dimmman
    dimmman
    2014-01-02

    • summary: GLX client, sound doesn't work in 3.0 alpha --> GLX client, sound doesn't work in 2.2 alpha
    • Description has changed:

    Diff:

    --- old
    +++ new
    @@ -1 +1 @@
    -Linux GLX client alpha 3.0 build from september13, the sound does not work, error message is "failed to initialize alsa". Works fine in 2.1 though.
    +Linux GLX client alpha 2.2 build from september13 (says 3.0 alpha but is 2.2 alpha), the sound does not work, error message is "failed to initialize alsa". Works fine in 2.1 though.
    
    • status: closed-invalid --> closed