new file disappears

Help
2006-09-02
2013-05-02
  • Hello,

    I mounted an exernal harddisk (ext3) an created a file:
    mac:~$ vi /Volumes/UNTITLED/test/hello.txt
    and checked the content:
    cat /Volumes/UNTITLED/test/hello.txt
    hello
    then I edited the same file again
    mac:~$ vi /Volumes/UNTITLED/test/hello.txt
    and checked
    mac:~ e$ cat /Volumes/UNTITLED/test/hello.txt
    cat: /Volumes/UNTITLED/test/hello.txt: No such file or directory

    oops the file wasn't there any more. It's reproduceable. I tried the same with an ext2 disk image.
    I seems to be ok with file which have been create by linux.

     
    • See if this new build fixes the problem (it works here):

      http://www.bergstrand.org/brian/software/bin/ext2fs.kext_14d4.zip

      unzip it and unmount all Ext2 file systems

      then:

      sudo -s
      # kextunload /Library/Extensions/ext2fs.kext
      # rm -rf /Library/Extensions/ext2fs.kext
      # mv ./ext2fs.kext /Library/Extensions/
      # chown -R root:wheel /Library/Extensions/ext2fs.kext

      Now you can mount your file systems again and the problem should be fixed. Let me know if it is or isn't.

      Thanks.

       
    • Hello,

      i tried the new driver and it works now. Thanks a lot!