Error 0x1FFFFFFF on external ext3 disk mount

Help
joh
2005-10-27
2013-05-02
1 2 > >> (Page 1 of 2)
  • joh
    joh
    2005-10-27

    Hello, when plugging in my 250G LaCie disk with an ext3 volume through usb, OS X fails to mount it, saying it contains no supported volumes. When I try to mount it from the ExtFSManager utility, I get the following message:

    Command: Mount
    Device: disk1s6
    Message: The filesystem may need repair. Please use Disk Utility to check the filesystem.
    Error: 0x1FFFFFFF

    My console.log says:
    2005-10-27 16:29:06.095 System Preferences[343] ExtFS: DiskArb failure for device 'disk1s6', with type -2147483648 and status 0x1FFFFFFF

    Mounting the disk from a terminal works perfectly, like so:
    mount -t ext2 /dev/disk1s6 /mount/point

    Any idea why my external disk is not recognized and mounted automatically?

    Thanks

     
    • I have the exact same problem and have not found any solution.  It mounts fine from the terminal, though, so my system's perfectly usable, but it's an annoyance.

      /T.J Thorsen, denmark

       
    • Gonzo
      Gonzo
      2006-01-10

      Are you using a CVS-Build or the latest published one?
      /T D.Becker

       
    • Same here - can mount and use from CLI but the GUI doesn't see the drive and I got the exact same errors msg when attempting to mount via ExtFSManager and Disk Utility

       
    • hi,
      i have the same problem (on Tiger), but in addition it doesnt work from the terminal either. i get the following error:

      mount_ext2: canceled automount on /dev/disk1s5 on PATH: Operation canceled

      this is a harddrive with a windows and ext2 partition which i recovered from my old laptop with a dead motherboard. pls help thanks

       
    • I have the same problem, but I can't mount with this command either:

      mount -t ext2 /dev/disk0s5 /mnt/linux/

      This is the end of the output:

      kextload: kld_load_from_memory() failed for module /System/Library/Extensions/ext2fs.kext/Contents/MacOS/ext2fs
      kextload: a link/load error occured for kernel extension /System/Library/Extensions/ext2fs.kext
      load failed for extension /System/Library/Extensions/ext2fs.kext
      (run kextload with -t for diagnostic output)
      mount_ext2: ext2 filesystem is not available

      Any ideas?

      Seastian Dahlgren
      Sweden

       
    • Solved by using the Ext2FS_1.4d1.dmg instead of 1.3..

      //Sebastian Dahlgren

       
    • Nope - new version did not help me I get the same error.

      OS X 10.4, AI PB, Lacie Bigger Disk and EXT3 format.

       
    • Grr, me too!

       
    • Got the same problem, how can I be sure that the Manager is the newest one? Mine says ExtFSManager 1.1.1 and has copyright 2003,2004,2006 is that the correct one?

       
    • thought I post as logged in, I'm the one with the question about versioning... using cli worked perfectly for me though...

       
    • anyone?

       
    • Anyone having this problem, please try the following release:

      http://www.bergstrand.org/brian/software/bin/Ext2FS_1.4d2.dmg

      Also, the "Operation canceled" error from mount_ext2 is because you have set the disk to not automount using the pref pane. Either turn automount back on or pass "-x" to mount_ext2 to override the pref.

       
    • I get get another error from the manager now, maybe 0x2FF.... perhaps, not quite sure though. Can find out if its important. I was just wondering though, I never get a question to write in my password, don't I need to sudo to mount? I have to sudo when using CLI.

      on the plus side though, seems like ignore permissions worked now, everythin is now owned by me:me and rwxrwxrwx ;)

       
      • Please post some of the pref pane Console output that occurs when trying to mount a partition. The exact error code is needed to find out what is going on.

         
    • How do I get the console output? I start it from then control center thing in OsX. It's my GF's PC, so I'm not an OSX expert. I'll get the code later.

       
      • Use the Console application (in Application/Utilities). There should be a bunch of debug info related to the pref pane, but the only part I'm interested in is the output during a mount attempt.

         
    • 2006-04-01 00:42:08.795 System Preferences[405] *** -[NSCFDictionary setObject:forKey:]: mutating method sent to immutable object
      2006-04-01 00:42:13.494 System Preferences[405] ExtFS: DiskArb failure for device 'disk2s1', with type 5 and status 0xF8DA000C
      2006-04-01 00:42:18.744 System Preferences[405] ExtFS: DiskArb failure for device 'disk2s1', with type 5 and status 0xF8DA000C
      2006-04-01 00:42:40.250 efssmartd[373] efssmartd: Warning Status for disk FUJITSU MHV2040AT Media: 'The status query failed due to an OS error.'.
      2006-04-01 00:42:58.628 efssmartd[288] efssmartd: Warning Status for disk FUJITSU MHV2040AT Media: 'The status query failed due to an OS error.'.

      ok, this is it. and the 0xF... error is the one your app spews out too. and again, using the cli tool works nice ;) although I have to use sudo.

       
      • 0xF8DA000C is "Operation not supported"

        So, the OS X disk manager thinks that the partition cannot be mounted. I don't know why this is, but if you want to investigate it further I can tell you how to put the OS X disk manager into debug mode.

         
    • please tell :)

       
      • Open Terminal and sudo to root.

        As root, edit the file /etc/mach_init.d/diskarbitrationd.plist (using vi or your own fav. editor).

        Change '/usr/sbin/diskarbitrationd' to '/usr/sbin/diskarbitrationd -d' (sans quotes of course).

        Save the file (and optionally verify it using plutil).

        Reboot your machine.

        Now the disk manager will log all kinds of debug info to:

        /var/log/diskarbitrationd.log

         
      • Could you check and see if "Don't Automount" is checked in the prefs pane for the partition you are trying to mount. If it is, then it's likely why the disk can't be mounted using the disk manager. And there's a bug in the pref pane that means you can't turn Automount back on.

        But, you can manually remove the prefs file (after quitting Sys Prefs) and that will reset the option. (/Library/Preferences/net.sourceforge.ext2fsx.ExtFSManager.plist).

         
    • the ext2fsx can't support OSX 10.4.7(or 10.4.8)...
      Apple have modify the Disk manager..
      So the new OS X Disk Manager thinks that the partition cannot be mounted....
      you can only manually mount ext2/ext3 partition instead of Automount...

       
    • I think the last post from anonymous is correct, I am also running 10.4.7 and I get the following error when I try to mount the  disk from the extfs extension in System Preferences:

      2006-10-15 13:42:42.036 System Preferences[221] ExtFS: DiskArb failure for device 'disk0s3', with type 5 and status 0xF8DA000C

      yet I can mount it manually fine.

       
    • Luca Spiller
      Luca Spiller
      2006-11-12

      Just wondering if anyone has found a solution to this problem?

      I can mount from the terminal fine, but the icon doesn't appear on the desktop, is there anyway to make this showup?

       
1 2 > >> (Page 1 of 2)