Problems after turning off automount

  • Hi,
    I installed Ext2 Filesystem 1.2 on a OSX 10.3.3 system that has three disks, one entirely dedicated to Linux.

    After the reboot, everything was fine, all my ext2/3 partitions appeared on the desktop. After disabling automaount for all ext2/3 partitions and enabling the ignore rights feature, I can not mount any ext2/3 partition any more!

    Using the ExtFs Manager from within the SystemControlPanel, I get the following error when trying to mount a ext2/3 partition (ps: I'm in Germany :):
    Vorgang: Aktivieren
    Gert: disk2s13
    Nachricht: Unbekannter Fehler
    Fehler: 0x1FFFFFFF

    Using the console I get the following:
    MDVK-035:/usr/local/sbin holale$ sudo ./e2fsck -f /dev/disk2s13
    e2fsck 1.35 (28-Feb-2004)
    Pass 1: Checking inodes, blocks, and sizes
    Pass 2: Checking directory structure
    Pass 3: Checking directory connectivity
    Pass 4: Checking reference counts
    Pass 5: Checking group summary information
    /home: 13193/2937600 files (40.8% non-contiguous), 1990600/5871494 blocks
    MDVK-035:/usr/local/sbin holale$ disktool -r
    Refreshing Disk Arbitration ...

    no disk appears on the desktop :( - next try:

    MDVK-035:/usr/local/sbin holale$ cd
    MDVK-035:~ holale$ mkdir Linux_home
    MDVK-035:~ holale$ mount_ext2 -o ro /dev/disk2s13 Linux_home/
    mount_ext2: open '/dev/disk2s13' failed, Permission denied
    you must be running as root to load modules into the kernel
    mount_ext2: ext2 filesystem is not available
    MDVK-035:~ holale$ sudo mount_ext2 -o ro /dev/disk2s13 Linux_home/
    mount_ext2: canceled automount on /dev/disk2s13 on /Users/holale/Linux_home: Operation canceled
    MDVK-035:~ holale$

    What am I missing, how can I revert to the first state. I uninstalled everything and installed it again - however no changes.

    Any help appreciated.

    Alexander Holst
    Pforzheim University of Applied Sciences
    <alex.holst [at] fh-pforzheim [dot] de>

    • Addenum:

      I just opened the Drive-Utility from /Applications/Utilities and found out that the unmountable partitions in question are both reported as "UNTITELED" instead of "disk1s12" or "disk1s13" respectively (as they had been before). The Linux swap partition on the same drive is still reported correctly as "disk1s11" inside the Drive-Utility panel.

      pdisk reports the following for the drive:
      MDVK-035:~ holale$ sudo pdisk /dev/rdisk1 -dump
      /dev/rdisk1  map block size=512
         #:                 type name                 length   base     ( size )
         1:  Apple_partition_map Apple                    63 @ 1      
         2:       Apple_Driver43*Macintosh                54 @ 64     
         3:       Apple_Driver43*Macintosh                74 @ 118    
         4:     Apple_Driver_ATA*Macintosh                54 @ 192    
         5:     Apple_Driver_ATA*Macintosh                74 @ 246    
         6:       Apple_FWDriver Macintosh               200 @ 320    
         7:   Apple_Driver_IOKit Macintosh               512 @ 520    
         8:        Apple_Patches Patch Partition         512 @ 1032   
         9:            Apple_HFS Boot_Linux           102400 @ 1544     ( 50.0M)
        10:      Apple_Bootstrap bootloader             2048 @ 103944   (  1.0M)
        11:      Apple_UNIX_SVR2 swap                1048576 @ 105992   (512.0M)
        12:      Apple_UNIX_SVR2 /root              41943040 @ 1154568  ( 20.0G)
        13:      Apple_UNIX_SVR2 /home              46971952 @ 43097608 ( 22.4G)
        14:           Apple_Free Extra                   280 @ 90069560

      Device block size=512, Number of Blocks=90069840
      DeviceType=0x0, DeviceId=0x0
      1: @ 64 for 23, type=0x1
      2: @ 118 for 36, type=0xffff
      3: @ 192 for 21, type=0x701
      4: @ 246 for 34, type=0xf8ff

      Could that be the cause of any of my problems? What caused the partitions to appear as "UNTITLED"? The names in the partition table haven't changed. I there a cure to that - preferably without wiping the drive and reinstalling Linux?

      Fortunately, I can still boot into Linux ;)

      Any help appreciated.

      Alexander Holst
      Pforzheim University of Applied Sciences
      <alex.holst [at] fh-pforzheim [dot] de>

    • The problem is, that you turned off automount. Therefore, the partition will never mount. Go back into Ext Manager, uncheck "Don't Automount", and then mount away.

      If you don't want to automount, but want to mount the drive manually, then you have to use 'mount_ext2 -x' the '-x' flag tells mount to ignore the global preferences. This is explained in the Readme.


    • Hi Brian,

      thanks for the quick help! - but I can't get into the features for any of the desired partitions any more! So, as a result, I can't turn automount back on!

      Every time I get back into the Ext Manager panel, everything is greyed out, even if I select an ext2/3 partition. All buttons are deactivated except for the mount button. As stated earlier, that will fail as well.

      I will try your command line version ("mount_ext2 -x") tomorrow, as the machine in question is at work. BTW, which README are you referring to? The one that is supplied on the .dmg didn't reveal that info.

      Thanks again!

      Alexander Holst
      Pforzheim University of Applied Sciences
      <alex.holst [at] fh-pforzheim [dot] de>

      • Yeah, that's a problem. Kind of a chicken and the egg thing. In order to change the vol prefs, the vol has to be mounted. So, I guess the easiest thing to do this is remove the prefs file:

        sudo rm /Library/Preferences/net.sourceforge.extt2fsx.*

        Then, open the Manager, mount the drive and change the options.


        PS, the Readme on the disk image mentions 'mount_ext2 -x' as a way to void the current preferences. It's in the "ExtFS Manager" section.

    • Hi Brian,

      sorry for the misconception on my side. Ereasing /Library/Preferences/net.sourceforge.extt2fsx.* solved everything. I used defaults to alter the prefs for ExtFS Manager. My bad.

      And yes, the -x flag is mentioned in the README - it just didn't appear to me that it would help anything, as I was under the impression, that ExtFS Manager would enable me to manually mount ext2/3 partitions that have been selected to not automaount, which is actually what I had in mind.

      So, I don't want my ext2/3 volumes automounted all the time, I only occasionally need access to them in order to get files across without rebooting. Does that mean, I can only mount them through the commandline? [as soon as I check the nonautomount feature for a volume, ExtFS Manager won't mount any volumes any more]

      Could that be a feature for future releases or is there a certain reason behind this behaviour? I would appreciate a "button mount" at any given time when in OSX, without the volumes mounted at boot time.

      Thanks again for your kind help and sorry for the misconception on my side!

      Alexander Holst
      Pforzheim University of Applied Sciences
      <alex.holst [at] fh-pforzheim [dot] de>

      • Actually, now that you point this out, the documentation/GUI is a little misleading as to the true nature of 'Don't Automount'. In its current form, it should be labeled 'Don't Mount'.

        I'll spare you the details, but suffice it to say that the Manager cannot currently determine what file system is on a disk until the disk is mounted. And if you've turned on 'Don't Automount' there is no way to mount the disk within the Manager: hence, the chicken and egg problem.

        I will definitely look into making this operation more user friendly in the future, but for now the only way to temporarily mount a disk marked as 'Don't Automount', is to use 'mount_ext2 -x' from the command line (or remove the global prefs file). If you use 'mount_ext2 -x' it should be followed by 'disktool -r' so the system disk manager is notified of the mount.


    • Hi Brian,

      thanks for the clarification!
      'mount_ext2 -x ...' in conjunction with 'disktool -r' does the trick! I'll write a short script to get the mount process accomplished. It'll get me around the 'the chicken and egg problem' for now.

      Thanks for your excellent work! It'll save me quite some time as I have to work under both systems and mol is not the solution in all circumstances.

      Alexander Holst
      Pforzheim University of Applied Sciences
      <alex.holst [at] fh-pforzheim [dot] de>

    • Hi
      I had the same problem since I made the same mistake ;)

      But I have the problem even if I rm the net.sourceforge.extt2fsx.* file...

      Even after rebooting, uninstall and re-install etc...

      some disks mount and some not. But all were fine before I check some check boxes in the options panels of the Manager...

      Now I must mount via command line. Not so bad but a little annoying.

      thanks for the clues.


      • Marco,

        Make double sure that you are removing the global copy from /Library/Preferences and not the copy in your home directory. The global copy is the one that matters. I'm betting this is your problem.

        Just to let everyone know, this issue is fixed for the next release. Not only will the pref pane let you change options for unmounted volumes, it is also smart enough to mount a volume that is marked as "Don't Automount" (w/o you having to uncheck "Don't Automount" first). I hope to have a beta ready within a month.

        Sorry about all of the confusion over this.