can only mount read only

Help
2004-01-23
2004-01-25
  • hi, I'm using ext2fsx_dev1.1b1. my ext3 partition will mount just fine as ext2 in panther, but only read-only! I can't get it to mount readwrite.

    I have tried both in prefs (unchecked the read-only box, unmounted it, mounted it again, it was read-only) and command line (sudo mount_ext2 -o rw /dev/disk0s10 /Users/kevin/data) and both ways it ends up read only.

    what am I missing? thanks

    kevin@desertsol.com

     
    • One of two things is going on:

      The R/O pref is being ignored, or the filesystem is not clean, and the kernel driver is refusing to mount it R/W. I would suspect the latter (the system log file will have an error if this is case: /var/log/system.log).

      To make sure run:

      /sbin/fsck_ext2 -yf /dev/disk0s10

      And then try the mount again. If it still doesn't work, then try adding a '-x' argument to mount_ext2. This will force it to ignore the preferences. Send me the prefs file at this point so I can see if something is going on. It is located in /Library/Preferences.

      Thanks.

       
    • Followup from private emails:

      Kevin:
      >It works for me now.
      >
      >it seems that it doesn't write the preferences file >until quit system preferences. I was mounting the >drive, changing the option, then umounting & >immediately remounting...if I change the option, >close prefs, then open prefs & remount it will mount >rw. and the other direction too...mount, change pref >back to read-only, it won't see the change until I quit >system prefs.

      Brian:
      Ahh, I see the problem. Yes, the changes won't be picked up until the pref pane exits, but you don't have to quit. Just click on another pref pane and then click back into the Ext2 pref pane.

      I'll see if I can come up with something better.