renaming a drive

Help
2005-02-04
2013-05-02
  • You can rename a drive as explained by willjwade in his post with the command e2label:
    1) Unmount the ext2 drive with the ExtFSManager (in the System Preferences).
    2) Do something like:
    sudo /usr/local/sbin/e2label /dev/disk0s5 YDL
    (command usage is: e2label device [newlabel])
    You can check the device with ExtFSManager
    3) Remount the ext2 drive. It will appear with the label you've defined (in the example YDL).

    Tested with Mac OS X 10.3.7 with ExtFSManager 1.3.

     
  • Actually, with 10.3.x you can rename the drive from the Finder. Richard must be running 10.2.x if a Finder rename didn't work.

    As for a custom icons, those are provided by the IO family device managers as they represent hardware not software. Ext2 is a filesystem plugin, IO family device drives are different beasts. You can just use the old standby of pasting a picture into the drive's Get Info panel. That will set a custom icon that the Finder (and most everything else) will use.

     
  • I'm running OSX.3.9, and I had the same problem as Richard and willjwade: my ubuntu partition automounted after rebooting, but was named Untitled. I was unable to rename the volume with Finder's Get Info Panel, since I only had Read permission. And I found no way of gaining administrator rights. The unmount-run e2label-remount trick worked like a charm, though. Might it have something to do with the fact that I have different logins for MacOSX and Ubuntu?

     
  • HandyMac
    HandyMac
    2006-12-17

    I'm new to Linux, recently installed Ubuntu on a partition in my iBook along with OS X 10.3.9. I came across Ext2FS for X, downloaded and installed v.1.3. The Linux volume mounts okay, but I wondered if I could give it a name & icon in OS X. I tried pasting an icon, but couldn't.

    In the forum I found this thread, in which the developer writes:

    "...with 10.3.x you can rename the drive from the Finder. ... You can just use the old standby of pasting a picture into the drive's Get Info panel."

    But I can't do either. The volume mounts with a simple question mark ? as name, not UNTITLED; in Get Info it says "You can only read" and "Format: Unknown". In the ExtFSManager preference pane, the volume appears as UNTITLED in the list, and the Info pane says:

    IOKit Name: untitled
    Device: disk0s3
    Mount Point: /Volumes/UNTITLED
    Writable: Yes
    Filesystem: Linux Ext3 (Journaled)
    Volume UUID: BBD41B90-3D34-4316-92D6-62A950A129F6
    Volume Name:
    Permissions Enabled: Yes
    Supports Journaling: Yes
    Journaled: No
    Supports Sparse Files: Yes
    Case Sensitive Names: Yes
    Case Preserved Names: Yes

    In the Options panel, "Mount Read Only" is NOT checked, so if I understand correctly, the drive should be writable?

    I tried checking "Mount Read Only", restarting, then unchecking it and restarting again. No help.

    I thought, well, according to ExtFSManager the disk should appear as UNTITLED, and should be writable, but somehow the Finder's not getting the message; so I ran AppleJack to clear out caches, etc. Still no change.

    Anyone have any ideas/suggestions?