Hi Dmitriy,

The jars referenced from oXygen (the data source drivers) are the jars compiled in the latest eXist-db version.

Switching to a version before the change (making the references apply to the older version) and everything works again.

I am on Mac OS X 10.9.2 running the oXygen build from April 3, 2014. I am still running java version 1.7.0_51, if that matters.

Jens

On 1 May 2014 at 11:32:46, Dmitriy Shabanov (shabanovd@gmail.com) wrote:

Did you update eXist's jar at oXygen?

On Thu, May 1, 2014 at 1:29 PM, Jens Ƙstergaard Petersen <oesterg@gmail.com> wrote:
Hi,

Does this mean that one cannot access eXist-db from oXygen?

Could not instantiate: ro.sync.db.nxd.exist.ExistSession due to: java.lang.UnsupportedClassVersionError: org/exist/xquery/XPathException : Unsupported major.minor version 51.0

is the error I get.


--
Dmitriy Shabanov