Hey everybody,

I installed eXist 2.0 RC (download package) on my machine (Win7, java 1.6.0_26, Firefox 17) yesterday. First of all: a big thank you to everybody how contributed to this release. You did an awesome job. The usability has greatly improved and it is much easier to work with.

 

Here are however a few issues that I noticed, as well as some thoughts I wanted to express. So here is the collection of these things (I hope I am not reporting already reported/fixed issues here, I tried to read all the previous feedback postings about 2.0 RC. But forgive me, if I oversaw something.):

 

Installer (GUI based)

·         On the first page, the welcome screen has scroll bars, even though the part that isn’t shown is only white. The area of the welcome screen should be reduced, so that the scrollbars don’t become necessary anymore, as they are a bit confusing/useless.

·         The last page of the installer is page 9 but on the bottom it says 9/10. However these is no next button, only the stop button. This is confusing and raises the suspicion that something went wrong. I ran the installer several times and I think I alternated each value at least once (though I am not sure, as I didn’t check for this specifically). So I assume there is no additional page, that just wasn’t displayed to me, because I didn’t select the right option. But even if there was, the last page should always be displayed as 10/10 (or 9/9).

·         I changed the data-directory, so it is not located within webapp/WEB-INF directory. However, when I first started eXist after the installation, the splash-screen didn’t disappear. After checking the log, I found this exception:

org.exist.util.DatabaseConfigurationException: cannot read data directory: C:\Users\<username>\eXist-2.0-RC\data

                at org.exist.util.Configuration.configureBackend(Configuration.java:783)

                at org.exist.util.Configuration.<init>(Configuration.java:223)

                at org.exist.util.SingleInstanceConfiguration.<init>(SingleInstanceConfiguration.java:55)

                at org.exist.util.SingleInstanceConfiguration.<init>(SingleInstanceConfiguration.java:47)

                at org.exist.jetty.JettyStart.run(JettyStart.java:156)

                at org.exist.launcher.Launcher$3$1.run(Launcher.java:112)

                After I stopped eXist, created the data-folder manually and restarted eXist, everything worked fine.

·         My password for the user ‘admin’ was not set. Instead when I wanted to login, the password was empty. At first I thought this might be connected to the data-directory bug, but I installed eXist again, this time with  the data directory at the default location and I had the same problem.

 

Collection Browser App

·         When uploading files, the selected files are listed in the “upload list”. This list however implies that one can select files in several iterations (each time using the button “Click to select file to upload”, for example to add files from several folders), however when new files is selected, the ones that are already in the list disappear. This  breaks with the (or at least my) expectation of how this list works.

·         Also in the upload-panel: The submit button should be below the file list, to have a classic top-to-bottom workflow.

·         Also in the upload-panel: The button  “Click to select file to upload” should be renamed to “Click to select files to upload” or “Click to select file(s) to upload” to show that it is also possible to select several files at once within the file dialog as this is now possible (not to be confused with the issue described above).

·         It would also be nice to have the option to rename a file as well within the Collection Browser.

 

BackUp App

·         When selecting an existing non-zip backup and pressing the download button, an error is shown. “exerr:ERROR for security reasons, the function only allows reading zipped backup archives [at line 56, column 13, source: /db/apps/dashboard/plugins/backup/backup.xql] In function: backup:retrieve() [66:36:/db/apps/dashboard/plugins/backup/backup.xql]”. Instead there should be an alert or something informing the user that downloads can only be done for zipped backups.

·         The Download button is larger than the “toolbar” section.

 

Package Manager App

·         In the compact view (no details), the package still use up quite a lot of screen real estate. It would be nicer if they were more compact, as it would be easier to overview them.

·         The icon of the eXide package is squeezed and therefore looks ugly. It should be displayed just a bit smaller and with correct width/hight-ration.

·         After updating a package an empty screen is shown and one has to close and open the package manager to get an updated view. This should be done automatically.

·         In the combined view of installed and uninstalled packages, it should be easier to distinguish between these two types. Currently it is just the shade of the grey background, but at least in the detailed view it would be helpful to also have an icon, or a text informing the user about the status of the package.

 

User Manager App (I assume this is work in progress and you are aware of these issues, but I will list them nonetheless)

·         When creating a new user the combo box for the user groups, no user groups are suggested initially (one would at least expect ‘dba’ and ‘guest’ there).

·         The combo box is an adjustable combo box, so one would expect to be able to type any group name in there and if it doesn’t exist, this user group is created. But if a user has an unknown user group, it will appear without any usergroup in the list, once the form is submitted.

·         Once the first custom user group is added through the specific form, the above issues disappear and new ones appear:

·         If there is a one user group, the dropdown will show that name and an entry “nogroup”. If there is more than one custom user group, the “nogroup” entry disappears.

·         When typing any text in the text field of the combo-box the text is automatically corrected to the name of the first user group in the list. It only shows the number of letters already typed and once one tries to type more letters than the first user group in the list has, the rest of the characters are removed. This makes it also impossible to assign to more than one group, as it should be possible judging from the admin entry.

·         When switching between the tree different forms (edit user, create user, create user group), the alert “TODO: confirm group” pops up occacionally.

·         When switching between the tree different forms, without pressing cancel on the first one, it is possible to have the form for creating/editing users and for creating user groups underneath each other.

 

Demo App

·         In the XForm&RestXQ Demp (http://localhost:8080/exist/apps/demo/examples/xforms/demo.html) when clicking on the button “Java Rest XQ”, the page is reloaded but the table doesn’t appear.

 

Documentation App

·         Function Documentation: When showing the details about a function which has parameters, the name of the parameter and its description are shown both in the column for the name and in the one for the description. Example: go to http://demo.exist-db.org/exist/apps/xqfdocs/index.html, click on “Browse” for “All Functions” and take a look at the first entry (versioning module, annotate function).

·         (It was already mentioned, but I still wanted to post this) The link to the javadoc (http://exist-db.org/api/index.html) produces a 404-Error. The link on the current eXist homepage which links to http://exist-db.org/exist/api/index.html also produces a 404.

 

So much for my first impression. Within the next days I will test our code with the RC version.

Thanks again for the great work.   

Bye

  David

 



View this message in context: My thoughts on and issues with eXist 2.0 RC
Sent from the exist-open mailing list archive at Nabble.com.