Thanks James,

Looks like its because I have it mounted through davfs. Using oxygens native webdav connection works perfectly. Very interesting. Thanks for the tips, looks like this solved the issue.

Sorry, for the lack of info before here is some more information for those who might be doing the same thing:

On Ubuntu 9.10 using oxygen to edit files that are mounted directly into the file system via davfs.



On Wed, Jun 30, 2010 at 3:19 PM, James Fuller <> wrote:
On 30 June 2010 21:13, Casey Jordan <> wrote:

When I save a file via web-dav, and then load that file via the rest interface or xquery the changes take 10-30 seconds to be shown.

doesn't sound right.

you didn't say what client you are using to connect or OS ...  some ideas to try:

* OS webdav integration is notoriously variable, have you tried a specific webdav client (usually built into FTP clients these days) over using your OS integration ?

* have you tried using oXygen XML editor connecting to database ... its the best way for rapid dev with eXist

* can u confirm that the file is actually there a few seconds after you save (using webdav to check) to isolate and see if its uploading the file via webdav or issue with REST ?

good luck, James Fuller

Casey Jordan
Jorsek Software LLC.
"CaseyDJordan" on LinkedIn, Twitter & Facebook
Cell (585) 348 7399
Office (585) 239 6060

This message is intended only for the use of the Addressee(s) and may
contain information that is privileged, confidential, and/or exempt from
disclosure under applicable law.  If you are not the intended recipient,
please be advised that any disclosure  copying, distribution, or use of
the information contained herein is prohibited.  If you have received
this communication in error, please destroy all copies of the message,
whether in electronic or hard copy format, as well as attachments, and
immediately contact the sender by replying to this e-mail or by phone.
Thank you.