Hi,

I changed my admin password from the admin panel by clicking on User Management, .  Now when I click on User Management I get the following error:

FODC0002: can not access collection 'Permission denied to open collection: /db/system/security/exist/accounts' [at line 184, column 31]
In function:
	users:display() [44:9:/home/epad/eXist/webapp/admin/users.xqm]
	users:process() [28:13:/home/epad/eXist/webapp/admin/users.xqm]
	users:main() [111:38:/home/epad/eXist/webapp/admin/users.xqm]
	admin:panel() [252:25:/home/epad/eXist/webapp/admin/admin.xql]

What does this mean?  How can I fix it?  Thanks.

Regards,
Debra



From: exist-open-request@lists.sourceforge.net
To: exist-open@lists.sourceforge.net
Sent: Thursday, April 25, 2013 1:10:59 PM
Subject: Exist-open Digest, Vol 84, Issue 59

Send Exist-open mailing list submissions to
        exist-open@lists.sourceforge.net

To subscribe or unsubscribe via the World Wide Web, visit
        https://lists.sourceforge.net/lists/listinfo/exist-open
or, via email, send a message with subject or body 'help' to
        exist-open-request@lists.sourceforge.net

You can reach the person managing the list at
        exist-open-owner@lists.sourceforge.net

When replying, please edit your Subject line so it is more specific
than "Re: Contents of Exist-open digest..."


Today's Topics:

   1. Re: eXist-based CMS: state of affairs? (wolfgang@exist-db.org)
   2. Re: xmldb:match-collection($regex) always returning        empty
      string (Erwan Guiochet)
   3. Re: eXist-based CMS: state of affairs?
      (ron.vandenbranden@kantl.be)
   4. Re: eXist-based CMS: state of affairs? (Dannes Wessels)
   5. Re: xmldb:match-collection($regex) always returning        empty
      string (Dannes Wessels)
   6. Re: xmldb:match-collection($regex) always returning empty
      string (christophe geiser)


----------------------------------------------------------------------

Message: 1
Date: Thu, 25 Apr 2013 11:05:41 +0200
From: wolfgang@exist-db.org
Subject: Re: [Exist-open] eXist-based CMS: state of affairs?
To: "ron.vandenbranden@kantl.be" <ron.vandenbranden@kantl.be>
Cc: eXist open <exist-open@lists.sourceforge.net>
Message-ID: <150786CB-B5B9-4DC9-87C6-F503CD2520E5@exist-db.org>
Content-Type: text/plain; charset=iso-8859-1

Hi Ron,

> This is exciting news! I had a brief look, and it might just fit the bill (what we're looking for is precisely a lightweight system for art historians ;-)). Looking forward to future development(s)!

Quite a coincidence. The wiki is currently being used for teaching purposes at the Heidelberg cluster "East-Asia and Europe" and there is (some) funding for it. We'll for sure be interested to cooperate. Apart from fixing the remaining quirks, we plan to add (until mid-June):

* annotations on regions within images: already works but is currently disabled due to some CSS issue
* integration with tamboti, the bibliographic tool which is also in the public repo
* integration with an eXist-based image database (ziziphus)
* full-screen slideshow component as alternative representation

> I noticed one installation quirk, however: installing apps with the package manager (via the dashboard) exits with an "Failed to connect to public repo" notification for all apps. OTOH, installation via the Package Repository tab on the Admin web app does succeed. Tested with out-of-the-box trunk code, rev. 18302.

I just tried on a different machine and it worked for me (windows server 2008). It would be interesting to see if there's more information in the web console of the browser.

Wolfgang


------------------------------

Message: 2
Date: Thu, 25 Apr 2013 02:19:57 -0700 (PDT)
From: Erwan Guiochet <erwan.guiochet@free.fr>
Subject: Re: [Exist-open] xmldb:match-collection($regex) always
        returning        empty string
To: exist-open@lists.sourceforge.net
Message-ID: <1366881597224-4659473.post@n4.nabble.com>
Content-Type: text/plain; charset=us-ascii

Hi,

testing it on the 2.0 RC2 ... got empty string too...
But i don't know how it works exactly.

I have tried to add a login before but nothing.

regards,



--
View this message in context: http://exist.2174344.n4.nabble.com/xmldb-match-collection-regex-always-returning-empty-string-tp4659365p4659473.html
Sent from the exist-open mailing list archive at Nabble.com.



------------------------------

Message: 3
Date: Thu, 25 Apr 2013 11:27:26 +0200
From: "ron.vandenbranden@kantl.be" <ron.vandenbranden@kantl.be>
Subject: Re: [Exist-open] eXist-based CMS: state of affairs?
To: wolfgang@exist-db.org
Cc: eXist open <exist-open@lists.sourceforge.net>
Message-ID: <5178F6FE.8020507@kantl.be>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed

Hi Wolfgang,

On 25/04/2013 11:05, wolfgang@exist-db.org wrote:
> Quite a coincidence. The wiki is currently being used for teaching purposes at the Heidelberg cluster "East-Asia and Europe" and there is (some) funding for it. We'll for sure be interested to cooperate. Apart from fixing the remaining quirks, we plan to add (until mid-June):
>
> * annotations on regions within images: already works but is currently disabled due to some CSS issue
> * integration with tamboti, the bibliographic tool which is also in the public repo
> * integration with an eXist-based image database (ziziphus)
> * full-screen slideshow component as alternative representation
>

My day keeps getting better and better! I already was impressed with the
annotation feature. If I can learn about customizing the wiki menu
structure and skinning the wiki seems a realistic option to consider!

>> I noticed one installation quirk, however: installing apps with the package manager (via the dashboard) exits with an "Failed to connect to public repo" notification for all apps. OTOH, installation via the Package Repository tab on the Admin web app does succeed. Tested with out-of-the-box trunk code, rev. 18302.
> I just tried on a different machine and it worked for me (windows server 2008). It would be interesting to see if there's more information in the web console of the browser.

Ah, I've just discovered a correlation with the version of the dashboard
in use. By default, a clean build (rev. 18273, Windows 7 Professional)
installs version 0.2.4, whose package manager is unable to install
anything from the public repo ("Failed to connect to public repo"). My
FireBug console logsthis response:

     { "error" : "Failed to connect to public repo", "trace" : "at apputil:install-from-repo(xs:string?, xs:anyURI?, xs:anyURI) [42:25:/db/apps/dashboard/modules/apputil.xql]" }


Yet, via the Package Repository tab in the Admin Web Application I was
able to update the dashboard to version 0.3.2. After that, most things
work from the package manager in the dashboard. Except for updating
eXide (1.0.6 was installed by default). Updating via the dashboard
package manager results in a "A package must contain an expath-repo.xml
and repo.xml descriptor" notification, and following response in Firebug:

     { "error" : "A package must contain an expath-repo.xml and repo.xml descriptor", "trace" : "at apputil:check-package(node()*) [144:21:F:\\devtools\\eXist\\exist-trunk\\webapp\\WEB-INF\\data\\expathrepo\\shared-0.2.2\\shared\\apputil.xql] at apputil:download-and-install(xs:anyURI, xs:anyURI) [116:35:F:\\devtools\\eXist\\exist-trunk\\webapp\\WEB-INF\\data\\expathrepo\\shared-0.2.2\\shared\\apputil.xql] at apputil:install-from-repo(xs:string?, xs:anyURI?, xs:anyURI) [58:47:F:\\devtools\\eXist\\exist-trunk\\webapp\\WEB-INF\\data\\expathrepo\\shared-0.2.2\\shared\\apputil.xql]" }


Again, the Package Repository tab in the Admin Web Application comes to
help: via this way, eXide can be updated to version 1.0.15 without problems.

Best,

Ron



------------------------------

Message: 4
Date: Thu, 25 Apr 2013 12:29:28 +0200
From: Dannes Wessels <dannes@exist-db.org>
Subject: Re: [Exist-open] eXist-based CMS: state of affairs?
To: Wolfgang Meier <wolfgang@exist-db.org>
Cc: eXist open <exist-open@lists.sourceforge.net>,
        "ron.vandenbranden@kantl.be" <ron.vandenbranden@kantl.be>
Message-ID:
        <CA+POi5BzMzCwTzW=V6KV6mPPqonAPrTKD04dv86t0Z_dUtHPRg@mail.gmail.com>
Content-Type: text/plain; charset="iso-8859-1"

On Thu, Apr 25, 2013 at 11:05 AM, <wolfgang@exist-db.org> wrote:

> > I noticed one installation quirk, however: installing apps with the
> package manager (via the dashboard) exits with an "Failed to connect to
> public repo" notification for all apps. OTOH, installation via the Package
> Repository tab on the Admin web app does succeed. Tested with
> out-of-the-box trunk code, rev. 18302.
>
> I just tried on a different machine and it worked for me (windows server
> 2008). It would be interesting to see if there's more information in the
> web console of the browser.
>
>
I see it myself often, thought  it was a local thingy. retry-helps most of
the times....
D.



--
eXist-db Native XML Database - http://exist-db.org
Join us on linked-in: http://www.linkedin.com/groups?gid=35624
-------------- next part --------------
An HTML attachment was scrubbed...

------------------------------

Message: 5
Date: Thu, 25 Apr 2013 20:34:57 +0200
From: Dannes Wessels <dizzzz@exist-db.org>
Subject: Re: [Exist-open] xmldb:match-collection($regex) always
        returning        empty string
To: christophe geiser <christophe.geiser@e-smile.org>
Cc: eXist DB ML <exist-open@lists.sourceforge.net>
Message-ID: <04B3DC09-062B-40FC-BED9-90DD8C2EA36D@exist-db.org>
Content-Type: text/plain; charset="us-ascii"

please could you provide an example?

On 17 Apr 2013, at 16:27 , christophe geiser <christophe.geiser@e-smile.org> wrote:

> It seems xmldb:match-collection is not behaving as expected (at least on my system, I could not have it return any collection, whatever the regex pattern I use for test) and always returns an empty string.
>
> Can somebody confirm it on the latest trunk ?

-------------- next part --------------
An HTML attachment was scrubbed...

------------------------------

Message: 6
Date: Thu, 25 Apr 2013 22:10:31 +0200
From: christophe geiser <christophe.geiser@e-smile.org>
Subject: Re: [Exist-open] xmldb:match-collection($regex) always
        returning empty string
To: Dannes Wessels <dizzzz@exist-db.org>
Cc: eXist DB ML <exist-open@lists.sourceforge.net>
Message-ID:
        <CAJC6Zbj_8g=n5kfgEoJzqMkC+CT571mijPGTZH4cJkh0QMPVLg@mail.gmail.com>
Content-Type: text/plain; charset="utf-8"

Thanks for the answer,
Well, I would have expected, for instance, that
xmldb:match-collection("db") returns all collection names. But there is
maybe something I am missing.
Cheers,
C.


On Thu, Apr 25, 2013 at 8:34 PM, Dannes Wessels <dizzzz@exist-db.org> wrote:

> please could you provide an example?
>
> On 17 Apr 2013, at 16:27 , christophe geiser <
> christophe.geiser@e-smile.org> wrote:
>
> It seems xmldb:match-collection is not behaving as expected (at least on
> my system, I could not have it return any collection, whatever the
> regex pattern I use for test) and always returns an empty string.
>
> Can somebody confirm it on the latest trunk ?
>
>
>


--
??s??? ??do?s????
e-Smile, solutions in monitoring and information management
--
-------------- next part --------------
An HTML attachment was scrubbed...

------------------------------

------------------------------------------------------------------------------
Try New Relic Now & We'll Send You this Cool Shirt
New Relic is the only SaaS-based application performance monitoring service
that delivers powerful full stack analytics. Optimize and monitor your
browser, app, & servers with just a few lines of code. Try New Relic
and get this awesome Nerd Life shirt! http://p.sf.net/sfu/newrelic_d2d_apr

------------------------------

_______________________________________________
Exist-open mailing list
Exist-open@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/exist-open


End of Exist-open Digest, Vol 84, Issue 59
******************************************