Hi

Sorry for the delay in returning with feedback: I got sidetracked with some other projects…

I did a clean build of eXist using the source code including thw 18376 commit, but to my surprise the problem persisted: the Null Pointer error is still displayed. The problem seems to be specific to that particular machine – I tried the stable eXist download on my personal laptop running Ubuntu 12.04 64bit and eXist installed and started without difficulty.

Could some other installed software be causing a conflict of some kind? No other software is using port 8080 on the problem machine, and I don’t think it has any “special” changes made to the desktop setttings…

/Michael

 

From: wolfgang@exist-db.org [mailto:wolfgang@exist-db.org]
Sent: 23 April 2013 21:53
To: Michael Cullen
Cc: 'Dannes Wessels'; 'eXist open Mailinglist'
Subject: Re: [Exist-open] exist-DB on Ubuntu 12.04

 

Hi,

 

I did a clean install of Ubuntu 12.10 today, but could not reproduce the launcher issue (neither with OpenJDK or the Oracle JDK). I tried to fix the NullPointerException though:

 

http://sourceforge.net/p/exist/code/18376

 

You will still not be able to open the dashboard from the system tray menu (it should work in the browser though), but at least the db should start up without complaining.

 

Wolfgang