Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

Installation on Ubuntu 10.10

Help
Anonymous
2010-10-17
2013-04-15

  • Anonymous
    2010-10-17

    I'm trying to install ExE on my Ubuntu 10.10 and its not working. Aparently there its a dependencies problem… I'll copy-paste terminal feedback of my last try:

    elipe@Marcelino:~/Escritorio$ sudo dpkg -i python2.5-exe_1.04.0.3532-ubuntu1_i386.deb 
    (Leyendo la base de datos ...  00%
    184714 ficheros y directorios instalados actualmente.)
    Preparando para reemplazar python2.5-exe 1.04.0.3532-ubuntu1 (usando python2.5-exe_1.04.0.3532-ubuntu1_i386.deb) ...
    Desempaquetando el reemplazo de python2.5-exe ...
    dpkg: problemas de dependencias impiden la configuración de python2.5-exe:
     python2.5-exe depende de python-zopeinterface (>= 3.0.0-6); sin embargo:
      El paquete `python-zopeinterface' no está instalado.
    dpkg: error al procesar python2.5-exe (--install):
     problemas de dependencias - se deja sin configurar
    Procesando disparadores para hicolor-icon-theme ...
    Procesando disparadores para man-db ...
    Procesando disparadores para desktop-file-utils ...
    Procesando disparadores para python-gmenu ...
    Rebuilding /usr/share/applications/desktop.es_ES.utf8.cache...
    Procesando disparadores para python-support ...
    Se encontraron errores al procesar:
     python2.5-exe
    felipe@Marcelino:~/Escritorio$ sudo apt-get install python-zopeinterface
    Leyendo lista de paquetes... Hecho
    Creando árbol de dependencias       
    Leyendo la información de estado... Hecho
    Nota, seleccionando «python-zope.interface» en vez de «python-zopeinterface»
    python-zope.interface ya está en su versión más reciente.
    Tal vez quiera ejecutar 'apt-get -f install' para corregirlo:
    Los siguientes paquetes tienen dependencias incumplidas:
     python2.5-exe : Depende: python-zopeinterface (>= 3.0.0-6)
    E: Dependencias incumplidas. Intente 'apt-get -f install' sin paquetes (o especifique una solución).
    

    It's in Spanish; it seems to me that the problem is that ExE depends on "python-zopeinterface", but in Ubuntu the name for that is "python-zope.interface"… I'm really not sure that this is the problem, but I'm pretty sure that I can't install ExE using straigh forward methods… Hope that someone can help me :)

     
  • Hi,

    You should try newest DEB available: exe_1.04.1.3601-ubuntu1_i386.deb which solves dependencies correctly, not the old '3532' you are trying to install.
    Regards,

     
  • Did you fix this? I have the same problem.

     
  • Jim Tittsler
    Jim Tittsler
    2011-08-27

    Yes, this was fixed on 2009-11-05.  Use a recent version of eXe (such as exe_1.04.1.3605-ubuntu1_i386.deb) and you shouldn't have this problem.

     
  • Rob Bosch
    Rob Bosch
    2011-11-19

    I have this very same problem. Using the latest installer on ubuntu 11.10 (oneiric)

    Anyone having the same issues? Any fixes?
    Weird that a fixed problem returns?

     
  • Jim Tittsler
    Jim Tittsler
    2011-11-19

    Are you sure there isn't something else going on?  I installed exe_1.04.1.3605-ubuntu1_i386.deb in a fresh 11.10 installation a few weeks ago and didn't have any problems.

    What is the exact error message you get during the installation?

     
  • Rob Bosch
    Rob Bosch
    2011-11-20

    I have a Dutch version so errormessages are in Dutch too. The errormessages are all python dependency messages:

    sudo dpkg -i exe_1.04.1.3605-ubuntu1_i386.deb
    Selecteren van voorheen niet geselecteerd pakket exe:i386.
    (Database inlezen … 226176 files and directories currently installed.)
    Uitpakken van exe:i386 (uit exe_1.04.1.3605-ubuntu1_i386.deb) …
    dpkg: vereistenproblemen verhinderen de configuratie van exe:i386:
    exe:i386 is afhankelijk van python (>= 2.4).
    exe:i386 is afhankelijk van python-support (>= 0.90.0).
    exe:i386 is afhankelijk van python-zopeinterface (>= 3.0.0-6) | python-zope.interface.
    exe:i386 is afhankelijk van python-imaging.
    dpkg: fout bij afhandelen van exe:i386 (-install):
    vereistenproblemen - blijft ongeconfigureerd
    Processing triggers for desktop-file-utils …
    Processing triggers for gnome-menus …
    Processing triggers for bamfdaemon …
    Rebuilding /usr/share/applications/bamf.index…
    Processing triggers for hicolor-icon-theme …
    Fouten gevonden tijdens behandelen van:
    exe:i386

     
  • Rob Bosch
    Rob Bosch
    2011-11-20

    Can't edit my post so I have to doublepost.

    I checked the dependencies and all dependencies ARE installed with higher versions than the dependencies indicate

     
  • Rob Bosch
    Rob Bosch
    2011-11-20

    triplepost
    exe:i386 is afhankelijk van python-zopeinterface (>= 3.0.0-6) | python-zope.interface

    Shouldn't that be python-zope.interface?? (as stated before in this thread)

     
  • Rob Bosch
    Rob Bosch
    2011-11-20

    A bit of a bummer, but the windows version (3590) works under wine. However, I would strongly prefer to have a native ubuntu package that works…..
    If you need any further debugging data, please say so.