Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#18 MD_RAID1 over Fibre Channel

Version_1.2
open
nobody
None
5
2003-07-16
2003-07-16
Joseph Jones
No

I'm really hoping you guys can help me with this one. I
am using a stock SLES8 installation which includes
EVMS. I have attached two disk subsystems to a host,
and I am trying to mirror across the two for protection.
The two systems are attach via two separate Fibre
HBA's.

Whenever I fail one of the disks in any way, the entire
system locks up and needs to be rebooted. What I am
doing is a pretty simple operation as far as I can tell. Is
there any issue with the MD_RAID1 driver working over
fibre channel?

Here is some information on the system:

linux:~ # lsmod
Module Size Used by Tainted: P
ide-cd 30564 0 (autoclean)
isa-pnp 32608 0 (unused)
ipv6 183636 -1 (autoclean)
st 29260 0 (autoclean) (unused)
sr_mod 14520 0 (autoclean) (unused)
cdrom 29120 0 (autoclean) [ide-cd
sr_mod]
sg 30272 0 (autoclean)
joydev 6112 0 (unused)
evdev 4800 0 (unused)
input 3488 0 [joydev evdev]
usb-ohci 21288 0 (unused)
usbcore 64832 1 [usb-ohci]
e100 77592 1
ext3 89128 1 (autoclean)
jbd 53988 1 (autoclean) [ext3]
lvm-mod 68192 0 (autoclean)
md_raid1 17372 1
md_core 51840 1 [md_raid1]
snapshot 21024 0 (unused)
os2lvm_vge 17952 0
AIXlvm_vge 40616 1
lvm_vge 29928 0
evms_drivelink 9248 0 (unused)
evms_bbr 16208 0 (unused)
gpt_part 6792 0
dos_part 12332 5
ldev_mgr 17316 2
evms_passthru 2144 1
evms 36684 11 [md_raid1 md_core
snapshot os2lvm_vge AIXlvm_vge lvm_vge
evms_drivelink evms_bbr gpt_part dos_part ldev_mgr
evms_passthru]
qla2300 202944 1
reiserfs 216660 2
ips 40640 7

linux:/var/log # uname -a
Linux linux 2.4.19-64GB-SMP #1 SMP Fri Feb 7 16:29:22
UTC 2003 i686 unknown
linux:/var/log #

Discussion

  • Joseph Jones
    Joseph Jones
    2003-07-16

    • milestone: 304464 --> Version_1.2
     
  • Joseph Jones
    Joseph Jones
    2003-07-16

    Logged In: YES
    user_id=823973

    More information:

    Here is the messages file while I am creating the array:

    Jul 16 09:55:33 linux kernel: evms: md core: [md0, level=1]
    raid array is not clean -- starting background reconstruction
    Jul 16 09:55:33 linux kernel: RAID level 1 does not need
    chunksize! Continuing anyway.
    Jul 16 09:55:33 linux kernel: evms: md raid1: <6>EVMS raid1:
    device sdc1 operational as mirror 1
    Jul 16 09:55:33 linux kernel: evms: md raid1: <6>EVMS raid1:
    device sdb1 operational as mirror 0
    Jul 16 09:55:33 linux kernel: evms: md raid1: <4>EVMS raid1:
    raid set md0 not clean; reconstructing mirrors
    Jul 16 09:55:33 linux kernel: evms: md raid1: <6>EVMS raid1:
    raid set md0 active with 2 out of 2 mirrors
    Jul 16 09:55:33 linux kernel: evms: md core: syncing RAID
    array md0
    Jul 16 09:55:33 linux kernel: evms: md core: minimum
    _guaranteed_ reconstruction speed: 100 KB/sec/disc.
    Jul 16 09:55:33 linux kernel: evms: md core: using maximum
    available idle IO bandwith (but not more than 100000 KB/sec)
    for reconstruction.
    Jul 16 09:55:33 linux kernel: evms: md core: using 508k
    window, over a total of 406548800 blocks.
    Jul 16 09:55:33 linux kernel: evms: Exporting EVMS Volume
    (117,255) from "/dev/evms/standby5-data".
    Jul 16 09:56:38 linux kernel: reiserfs: found format "3.6" with
    standard journal
    Jul 16 09:56:42 linux kernel: reiserfs: checking transaction log
    (evms(117,255)) for (evms(117,255))
    Jul 16 09:56:42 linux kernel: reiserfs: using ordered data mode
    Jul 16 09:56:42 linux kernel: Using r5 hash to sort names

    Here is what it looks like when I disable the port to the
    storage on the switch:

    Jul 16 09:57:44 linux kernel: scsi(2): Waiting for LIP to
    complete...
    Jul 16 09:57:44 linux kernel: scsi2: Topology - (F_Port), Host
    Loop address 0xffff
    Jul 16 09:58:45 linux kernel: scsi(2:0:0:0): DEVICE RESET
    ISSUED.
    Jul 16 09:58:46 linux kernel: scsi(2:0:0:0): LOOP RESET
    ISSUED.
    Jul 16 09:58:47 linux kernel: scsi(2): Waiting for LIP to
    complete...
    Jul 16 09:58:47 linux kernel: scsi2: Topology - (F_Port), Host
    Loop address 0xffff
    Jul 16 09:58:47 linux kernel: scsi(2): Waiting for LIP to
    complete...
    Jul 16 09:58:47 linux kernel: scsi2: Topology - (F_Port), Host
    Loop address 0xffff

    Shortly after I get that last message, the system locks up
    completely. There doesn't seem to be anything in the
    evmsEngine.log...

    I would really appreciate any help.

    Thanks,
    Joe