Thanks a mill Pat,

I installed rubygems-1.7.2 and only got the depreciation warning, but it seemed to install my gems fine ;)

All seems to be working perfectly , thanks !!

------------------------------
Thanks for your time.

Gareth



On 16 May 2011 18:21, Pat O'Brien <obrien.patrickl@gmail.com> wrote:
I get this same error with the following setups:

rubygems 1.8.2
ruby 1.8.7-p174
OS X 10.6.6

rubygems 1.8.2
ruby 1.8.7-p299
CentOS 5.5 x86_64

but it works fine with rubygems 1.3.7 and the following setup:
rubygems 1.3.7
ruby 1.8.7-p299
CentOS 5.5 x86_64

Looks like it's a rubygems 1.8.2 issue.

-pat



On Mon, May 16, 2011 at 9:36 AM, Spyda <webspyda@gmail.com> wrote:
Thanks a mill for your response,
I cant even get to the unicorn start because I get stuck just installing the gems :(
I have reinstalled all the deb packages, even installed the rubygems from the tgz package and managed to upgrade gem from 1.8.1 to 1.8.2


I am running Debian Squeeze (just upgraded from lenny)

Here is the info you were looking for:

server# dpkg --list |grep ruby
ii  libruby1.8                          1.8.7.302-2                  Libraries necessary to run Ruby 1.8
ii  ruby                                4.5                          An interpreter of object-oriented scripting language Ruby
ii  ruby-dev                            4.5                          Header files for compiling extension modules for Ruby
ii  ruby1.8                             1.8.7.302-2                  Interpreter of object-oriented scripting language Ruby 1.8
ii  ruby1.8-dev                         1.8.7.302-2                  Header files for compiling extension modules for the Ruby 1.8
ii  rubygems                            1.3.7-3                      package management framework for Ruby libraries/applications
ii  rubygems1.8                         1.3.7-3                      package management framework for Ruby libraries/applications


server# gem -v
1.8.2

server# rake gems:install --trace
(in /opt/etch-3.19.0/server)
DEPRECATION WARNING: Rake tasks in vendor/plugins/open_flash_chart/tasks are deprecated. Use lib/tasks instead. (called from /usr/lib/ruby/gems/1.8/gems/rails-2.3.11/lib/tasks/rails.rb:10)
** Invoke gems:install (first_time)
** Invoke gems:base (first_time)
** Execute gems:base
** Invoke environment (first_time)
** Execute environment
rake aborted!
undefined method `name' for "actionmailer":String
/usr/lib/ruby/gems/1.8/gems/rails-2.3.11/lib/rails/gem_dependency.rb:277:in `=='
/usr/local/lib/site_ruby/1.8/rubygems/dependency.rb:217:in `==='
/usr/local/lib/site_ruby/1.8/rubygems/dependency.rb:217:in `matching_specs'
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:36:in `find_all'
/usr/local/lib/site_ruby/1.8/rubygems/specification.rb:403:in `each'
/usr/local/lib/site_ruby/1.8/rubygems/specification.rb:402:in `each'
/usr/local/lib/site_ruby/1.8/rubygems/dependency.rb:216:in `find_all'
/usr/local/lib/site_ruby/1.8/rubygems/dependency.rb:216:in `matching_specs'
/usr/local/lib/site_ruby/1.8/rubygems/dependency.rb:238:in `to_specs'
/usr/local/lib/site_ruby/1.8/rubygems/dependency.rb:256:in `to_spec'
/usr/local/lib/site_ruby/1.8/rubygems.rb:1182:in `gem'
/usr/lib/ruby/gems/1.8/gems/rails-2.3.11/lib/rails/gem_dependency.rb:75:in `add_load_paths'
/usr/lib/ruby/gems/1.8/gems/rails-2.3.11/lib/initializer.rb:301:in `add_gem_load_paths'
/usr/lib/ruby/gems/1.8/gems/rails-2.3.11/lib/initializer.rb:301:in `each'
/usr/lib/ruby/gems/1.8/gems/rails-2.3.11/lib/initializer.rb:301:in `add_gem_load_paths'
/usr/lib/ruby/gems/1.8/gems/rails-2.3.11/lib/initializer.rb:132:in `process'
/usr/lib/ruby/gems/1.8/gems/rails-2.3.11/lib/initializer.rb:113:in `send'
/usr/lib/ruby/gems/1.8/gems/rails-2.3.11/lib/initializer.rb:113:in `run'
/opt/etch-3.19.0/server/config/environment.rb:13
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:36:in `gem_original_require'
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:36:in `require'
/usr/lib/ruby/gems/1.8/gems/activesupport-2.3.11/lib/active_support/dependencies.rb:182:in `require'
/usr/lib/ruby/gems/1.8/gems/activesupport-2.3.11/lib/active_support/dependencies.rb:547:in `new_constants_in'
/usr/lib/ruby/gems/1.8/gems/activesupport-2.3.11/lib/active_support/dependencies.rb:182:in `require'
/usr/lib/ruby/gems/1.8/gems/rails-2.3.11/lib/tasks/misc.rake:4
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:636:in `call'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:636:in `execute'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:631:in `each'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:631:in `execute'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:597:in `invoke_with_call_chain'
/usr/lib/ruby/1.8/monitor.rb:242:in `synchronize'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:590:in `invoke_with_call_chain'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:583:in `invoke'
/usr/lib/ruby/gems/1.8/gems/rails-2.3.11/lib/tasks/gems.rake:17
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:636:in `call'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:636:in `execute'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:631:in `each'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:631:in `execute'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:597:in `invoke_with_call_chain'
/usr/lib/ruby/1.8/monitor.rb:242:in `synchronize'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:590:in `invoke_with_call_chain'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:607:in `invoke_prerequisites'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:604:in `each'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:604:in `invoke_prerequisites'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:596:in `invoke_with_call_chain'
/usr/lib/ruby/1.8/monitor.rb:242:in `synchronize'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:590:in `invoke_with_call_chain'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:583:in `invoke'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2051:in `invoke_task'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2029:in `top_level'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2029:in `each'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2029:in `top_level'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2068:in `standard_exception_handling'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2023:in `top_level'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2001:in `run'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2068:in `standard_exception_handling'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:1998:in `run'
/usr/lib/ruby/gems/1.8/gems/rake-0.8.7/bin/rake:31
/usr/bin/rake:19:in `load'
/usr/bin/rake:19


----------------------------------
Thank you for your time.

Gareth


On 16 May 2011 17:21, Jason Heiss <jheiss@aput.net> wrote:
Rails is somehow failing to assemble itself, but that particular error is a new one on me.  Google turned up a few other folks with the same error message, but no obvious solution.

A couple of thoughts though.  I don't know if any of these will help narrow down the problem.

If you're trying to set up a production install you'll want to set your RAILS_ENV environment variable to "production" before running any commands.  Otherwise rails will default to the "development" database configuration in config/database.yml.  Eventually you'll want an init script or similar that sets RAILS_ENV before firing up unicorn, but for the rake commands to install gems and setup the database it's easiest to just set it manually.

What version of rubygems do you have?  (gem -v)  It's possible you have an old version that isn't compatible with newer versions of rails.  You can update with "sudo gem update --system" and see if that changes anything.

Jason

On May 16, 2011, at 2:25 AM, Gareth Greener wrote:

> Hi,
>
> I am quite new to Ruby and I have etch working on a test machine, but really struggling to install it in my production environment.
> I have followed all the steps to install but I get an error on the below:
>
> server# rake gems:install
> (in /opt/etch-3.19.0/server)
> DEPRECATION WARNING: Rake tasks in vendor/plugins/open_flash_chart/tasks are deprecated. Use lib/tasks instead. (called from /usr/lib/ruby/gems/1.8/gems/rails-2.3.11/lib/tasks/rails.rb:10)
> rake aborted!
> undefined method `name' for "actionmailer":String
>
> (See full trace by running task with --trace)
>
> *** LOCAL GEMS ***
>
> actionmailer (2.3.11, 2.3.8)
> actionpack (2.3.11, 2.3.8)
> activerecord (2.3.11, 2.3.8)
> activeresource (2.3.11, 2.3.8)
> activesupport (2.3.11, 2.3.8)
> etch (3.19.0)
> facter (1.5.8)
> kgio (2.4.0)
> libxml-ruby (1.1.2)
> rack (1.1.2)
> rails (2.3.11, 2.3.8)
> rake (0.8.7)
> sqlite3 (1.3.3)
> sqlite3-ruby (1.3.3)
> unicorn (3.6.2)
>
>
> ------------------------------
> Thanks for your time.
>
> Gareth
>
> ------------------------------------------------------------------------------
> Achieve unprecedented app performance and reliability
> What every C/C++ and Fortran developer should know.
> Learn how Intel has extended the reach of its next-generation tools
> to help boost performance applications - inlcuding clusters.
> http://p.sf.net/sfu/intel-dev2devmay_______________________________________________
> etch-users mailing list
> etch-users@lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/etch-users



------------------------------------------------------------------------------
Achieve unprecedented app performance and reliability
What every C/C++ and Fortran developer should know.
Learn how Intel has extended the reach of its next-generation tools
to help boost performance applications - inlcuding clusters.
http://p.sf.net/sfu/intel-dev2devmay
_______________________________________________
etch-users mailing list
etch-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/etch-users