Stop esniper from bidding

Help
Kevin
2008-02-12
2013-05-13
  • Kevin
    Kevin
    2008-02-12

    Is there a way to stop esniper from bidding? What I mean is say I ran esniper using an auction file and I realized I put in the wrong amount of money for an auction. Is there a way to quit esniper or to tell it not to bid on that item?

     
    • Rolf
      Rolf
      2008-02-12

      Assuming you are running ensiper on Linux.

      If you have only one esniper process "killall esniper".  If you have more than one and want to kill only one process, look up the PID with "ps faux|grep esniper" and then "kill $PID_number".

       
    • Kevin
      Kevin
      2008-02-12

      Thanks, I knew about using ps and kill commands, I was just wondering if there was something already built into esniper. Something like "esniper auction_file.txt quit". Oh well, not too big of a deal, the kill command works fine.

       
      • Scott Nicol
        Scott Nicol
        2008-02-12

        If you use the snipe script to start auctions, you can use it to monitor and kill auctions by auction file name.  The script is in the frontends directory.  You can get usage with snipe -?.

        In your example, you'd start esniper with:

        snipe auction_file.txt

        You could see what's running with:

        snipe

        then get info on auction_file.txt:

        snipe -i auction_file.txt

        and if you want to kill it:

        snipe -k auction_file.txt

         
    • Kevin
      Kevin
      2008-02-12

      Thanks. I didn't know esniper had a this. I use Debain Lenny and install and keep up-to-date with the package manager and there is no frontend directory. I might just have to use the downloaded version from here from now on.

      Oh, by the way Scott, great program. I love it and recommend it to everyone.

       
      • Scott Nicol
        Scott Nicol
        2008-02-13

        You're welcome, glad you like it.

         
    • Quy NGUYEN DAI
      Quy NGUYEN DAI
      2009-02-21

      @Scott Nicol: are you sure there is "-k" option ?

      > /home/foo/apps/bin/esniper -k test.txt
      /home/quy/apps/bin/esniper: invalid option -- k
      usage: esniper [-bdhHnmPrUv] [-c conf_file] [-l logdir] [-p proxy] [-q quantity]
             [-s secs|now] [-u user] (auction_file | [auction price ...])

      Try "esniper -h" for more help.

      I use 2.19.0 on Linux.