#592 esniper did not bid

open
nobody
None
5
2012-01-13
2012-01-13
Mario
No

Automated esniper bug report.
esniper version 2.26.0
libcurl/7.21.4 OpenSSL/0.9.8n zlib/1.2.5 libidn/1.19
Error encountered in function preBid in auction.c line 341
auction = 120837890157, price = 32, remain = 0
latency = 0, result = -1, error = 11
buf = 0x6f94d0, size = 70968, read = 0x6f94d0
time = 1326480011, offset = 0
pagename = "Xrite Monaco Optix XR Colorimeter for Monitor Calibration | eBay", pageid = "(null)", srcid = "(null)"
specified options or config values:
1 x username(u) = ***
1 x password() = ***
1 x seconds(s) = 10
2 x quantity(q) = 1
1 x (f) = "./asta12gen11"
1 x reduce() = 1
1 x bid() = 1
1 x debug(d) = 0
1 x batch(b) = 1
1 x logdir(l) = "/home/mario/.snipe"
cannot find bid uiid
then upload and attach esniper.31366.1.bug.html and click submit.
Cannot get bid key
Auction 120837890157: Bid uiid not found

Discussion

  • Mario
    Mario
    2012-01-13

     
  • Bodo
    Bodo
    2012-01-15

    There seems to be a problem on the sourceforge site. I get an error message when I try to download the attached file esniper.31366.1.bug.html. Please send me this file to bomm@users.sourceforge.net

    Bodo

     
  • Bodo
    Bodo
    2012-02-28

    There might have been a timing problem because esniper tried to prepare for bidding when the auction ended. (Maybe the seller ended the auction early?)
    Or there might have been network problems that prevented esniper from preparing for bidding at the right time and it retried until the auction was over.
    The only open problem is that esniper should print an normal error message like "auction ended" instead of requesting a bug report.