On 3/25/07, julian@precisium.com <julian@precisium.com> wrote:
Hello Kiran,
 
Perhaps you could give some more info on the steps you took to install it?
The more info you give - the more likely someone may just try to duplicate your steps and checkout the problem.
 
I've installed it on a windows 2000 box in the past..  but I think it was a pretty manual affair.
I compiled each .yaws file and just treated it as an erlang library rather than as a standalone application - but that's a tedious way to do it.
 
Also.. why are you using 1.66 & not 1.68?
 
I'm assuming you're downloading from http://yaws.hyber.org/download/    or has someone provided a more windows-friendly package that I'm not aware of?
 
Cheers,
Julian
 
----- Original Message -----
Sent: Saturday, March 24, 2007 6:04 PM
Subject: [Erlyaws-list] Yaws crash on startup, on Windows - repost

Second attempt at posting this question.

Hello list,
I successfully installed yaws on my WindowsXP box, and when I try to start it using the yaws -i option, it crashes.
I noticed that a similar issue has been reported on the yaws wiki: http://yaws.hyber.org/wiki/showPage.yaws?node=SomeProblemsAndTheirSolution , and is not yet answered.
Searched this mailing list, and used Google too... not too much luck.
yaws version: Yaws 1.66
erl: 5.5.1

This is my first attempt at learning Yaws, so any help will be useful. Thanks.
Kiran


-------------------------------------------------------------------------
Take Surveys. Earn Cash. Influence the Future of IT
Join SourceForge.net's Techsay panel and you'll get the chance to share your
opinions on IT & business topics through brief surveys-and earn cash
http://www.techsay.com/default.php?page=join.php&p=sourceforge&CID=DEVDEV


_______________________________________________
Erlyaws-list mailing list
Erlyaws-list@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/erlyaws-list



Klacke, and Julian,
Thanks for the response.

List,
Let me elaborate the steps that I've taken to install and configure Yaws.

Environment:
Windows XP SP2
Erlang Ver: 5.5.1
Yaws Ver: 1.68 .. my initial posting had 1.66, following which I downloaded the latest version.
Cygwin Ver: Cygwin DLL cygwin-1.5.24-2

Followed the build, configure, and run instructions listed here: http://yaws.hyber.org/yaws.pdf
Repeating the steps I followed, just to double-check.
  1. Downloaded yaws: http://yaws.hyber.org/download/yaws-1.68.tar.gz
  2. Extracted the contents to a <drive>/yaws folder.
  3. Opened cygwin, and cd to yaws folder.
  4. ./configure && make
  5. make local_install
  6. ~/bin/yaws -i
This is when I receive the error:
------------------ERROR REPORT---------------------
$ ~/bin/yaws -i

=PROGRESS REPORT==== 26-Mar-2007::19:09:29 ===
          supervisor: {local,sasl_safe_sup}
             started: [{pid,<0.33.0>},
                       {name,alarm_handler},
                       {mfa,{alarm_handler,start_link,[]}},
                       {restart_type,permanent},
                       {shutdown,2000},
                       {child_type,worker}]

=PROGRESS REPORT==== 26-Mar-2007::19:09:30 ===
          supervisor: {local,sasl_safe_sup}
             started: [{pid,< 0.34.0>},
                       {name,overload},
                       {mfa,{overload,start_link,[]}},
                       {restart_type,permanent},
                       {shutdown,2000},
                       {child_type,worker}]
{"init terminating in do_boot",{undef,[{yaws,start,[]},{init,start_it,1},{init,s
tart_em,1}]}}

Crash dump was written to: erl_crash.dump
init terminating in do_boot ()


------------------END ERROR REPORT---------------------

I have a crash_dump file, if that's of any help - 53KB gzipped file. Will email directly to an e-mail address (the mailing list requires the mail to be 40KB or less).
Please let me know if you require any further information.
Thanks for your time and help,
Kiran