I ran into this same problem with yaws 1.97 and Ubuntu, and had to change a file in yaws to get rid of the problem.  But this should have been fixed in yaws 1.98.  I successfully compiled yaws 1.98 a few days ago using yaws-1.98.tar.gz file downloaded from here: http://yaws.hyber.org/download/.  Is this the tar ball you're using?




On Mon, Dec 16, 2013 at 4:20 AM, Christopher Faulet <christopher.faulet@capflam.org> wrote:
On 16/12/2013 01:59, mayamatakeshi wrote:
> I am using:
> Erlang R16B03 (erts-5.10.4) [source] [64-bit] [async-threads:10] [hipe]
> [kernel-poll:false]
>
> I tried with CentOS 6.4 and 6.5 and in both I get this:
>
> "/usr/local/bin/erlc" -Werror  -pa ../../yaws -I ../include -o ../ebin
> yaws_websockets.erl
> compile: warnings being treated as errors
> yaws_websockets.erl:1258: crypto:sha/1 is deprecated and will be removed
> in in a future release; use crypto:hash/2
> make[1]: *** [../ebin/yaws_websockets.beam] Error 1
> make[1]: Leaving directory `/usr/local/src/yaws-1.98/src'
> make: *** [all] Error 1
>

Hi,

Maybe you need to re-run the configure script. And to be sure, you also
could regenerate this script by running following command:

 autoreconf -fi

If crypto:hash/2 is found, HAVE_CRYPTO_HASH variable must be set to true
in include.mk.

Let me know if your problem persist.
--
Christopher



------------------------------------------------------------------------------
Rapidly troubleshoot problems before they affect your business. Most IT
organizations don't have a clear picture of how application performance
affects their revenue. With AppDynamics, you get 100% visibility into your
Java,.NET, & PHP application. Start your 15-day FREE TRIAL of AppDynamics Pro!
http://pubads.g.doubleclick.net/gampad/clk?id=84349831&iu=/4140/ostg.clktrk
_______________________________________________
Erlyaws-list mailing list
Erlyaws-list@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/erlyaws-list