so both of my problems were false alarms. 
sorry about them.
thanks for the answers.
f

On Fri, Sep 23, 2011 at 12:54 AM, Steve Vinoski <vinoski@ieee.org> wrote:
On Wed, Sep 21, 2011 at 3:23 AM, Ferenc Vehmann
<ferenc.vehmann@bitongo.com> wrote:
> Not related to websocket, but I wanted to mention that compiling yaws from
> git doesn't work on OSX (Snow Leopard 10.6.6).
> After autoconf ./configure would fail. It seemed that the EOL being in DOS
> format in the scripts was the problem.
> After that ./configure worked but make failed.
> Then dos2unix scritps/* helped for make to go further but failed again.
> yaws_generated.erl didn't contain modue definition. (empty file)
> after the rm src/yaws_generated.erl, make worked.
> Getting directly the tar.gz, ./configure && make works just fine.

Snow Leopard? We built on that for ages, and it always worked fine. I
now build on Lion fine as well.

Neither Klacke nor I work on Windows -- I don't even have a Windows
machine at all -- so getting DOS EOLs in the code is very unlikely.
Perhaps your git is misconfigured and it's adding a DOS EOL? If you
keep having problems in this area maybe you could capture the output
of a session showing these problems and send it to me, but check your
git EOL handling config first.

--steve



--
Ferenc Vehmann
Co-Founder

Bitongo Ltd.
http://www.bitongo.com
ferenc.vehmann@bitongo.com