Have recompiled it now(have it done before, but not for produce the debug output)

What i think is interesting, if i compile the module with the new version and than install the old, there is no error.
Could it be possible, that i use the wrong path?

anyway i looked at the end of the install output and found a difference.

at old install:
sh  ./Install /usr/local "/usr/bin/erl" \
        "" /etc/ /var/ /usr/lib/erlang/bin/
at new install:
sh  ./Install /usr/local "/usr/local/bin/erl" \
        "" /etc/ /var/ /usr/local/lib/erlang/bin/

but the paths are all the same

** etc files went into        /etc
** executables went into      /usr/local/bin
** library files went into    /usr/local/lib/yaws
** var files went into        /var
** default docroot went into  /var/yaws/www


/usr/bin/erl is i think the installation from the dist
/usr/bin/erl --version
Erlang (BEAM) emulator version 5.6.5 [source] [smp:2] [async-threads:0] [kernel-poll:false]

/usr/local/bin/erl is the one, i compiled myself some time ago
/usr/local/bin/erl --version
Erlang R13B03 (erts-5.7.4) [source] [smp:2:2] [rq:2] [async-threads:0] [hipe] [kernel-poll:false]


why is there a difference? i think i compiled erlang after i installed yaws, so the configure script had the old paths.
For testing i rund the configure script to renew the paths and yes, now both versions use the same paths at this point.
But there is no difference. Old yaws run fine, new does not.

2010/9/17 Steve Vinoski <vinoski@ieee.org>
On Fri, Sep 17, 2010 at 8:31 AM, Daniel Fahlke
<flyingmana@googlemail.com> wrote:
> Have tried it with old and new yaws version.

<snip/>

Question: did you recompile your arbit_404_handler module against the
newer version of yaws before running it there? If not, try that. There
are changes in the gconf record between the versions.

--steve