When I use yaws:add_server to add servers for erlyweb apps with the same servername and port, only the last server gets recognized.  Both apps work fine when added independently, and both apps appear in the yaws_api:getconf(), but only the last server added actually works, other servers return 404 when accessed.  Is this the expected behavior or a bug?

start_yaws(Port)->
      code:add_patha("/opt/local/lib/yaws/ebin"),
     
     yaws:start_embedded("./apps/blog/www",
       [{servername, "localhost"},
        {port, Port},
        {appmods,[{"/blog",erlyweb}]},
        {opaque,[{"appname",blog}]},
        {allowed_scripts,[]}],
       [{logdir,"./log"}]),
     
     yaws:add_server("./apps/wiki/www",
       [{servername, "localhost"},
        {port, Port},
        {appmods,[{"/wiki",erlyweb}]},
        {opaque,[{"appname",wiki}]},
        {allowed_scripts,[]}]).


print_yaws_conf() ->
  io:format("~p~n",[yaws_api:getconf()]).

{ok,{gconf,"/opt/local/lib/yaws",
           false,
           204,
           "./log",
           ["/opt/local/lib/yaws/examples/ebin"],
           [],
           15000,
           400,
           1000000,
           8000,
           10240,
           10000000,
           30,
           ["/opt/local/lib/yaws/examples/include"],
           "/usr/bin/php-cgi",
           "Yaws 1.71",
           [],
           "/Users/rcb/.yaws",
           false},
    [[{sconf,3000,
             3,
             [],
             undefined,
             undefined,
             "./apps/wiki/www",
             [],
             {127,0,0,1},
             "localhost",
             undefined,
             undefined,
             [],
             nolimit,
             [{"/wiki",erlyweb}],
             yaws_404,
             yaws_404,
             yaws,
             [{"appname",wiki}],
             undefined,
             [],
             []},
      {sconf,3000,
             3,
             [],
             undefined,
             undefined,
             "./apps/blog/www",
             [],
             {127,0,0,1},
             "localhost",
             46,
             undefined,
             [],
             nolimit,
             [{"/blog",erlyweb}],
             yaws_404,
             yaws_404,
             yaws,
             [{"appname",blog}],
             undefined,
             [],
             []}]]}