To answer my own question ...:
autoconf; ./configure --prefix=$HOME; make; make local_install
does it... (you need $HOME/var/yaws)
Why is it that the solutions comes after hitting the send button :).
Regards,
George

-------- Original Message --------
Subject: Problem doing a local_install on Ubuntu 11.04
Date: Thu, 14 Jul 2011 20:32:15 +0200
From: George Stoianov <gstoyanoff@gmail.com>
To: erlyaws-list@lists.sourceforge.net


Hello everyone,

I am YAWS newbie and I just cloned the repo from GitHub and did the:

./configure; make; make local_install

which leads to:

                ...
                make[1]: Leaving directory 
`/home/gs/git-repos/yaws/scripts'
                rm -rf yaws-1.90.script yaws-1.90.boot
                rm -rf yaws-1.90.rel yaws-1.90.tar.gz
                (cd scripts && make local_install)
                make[1]: Entering directory 
`/home/gs/git-repos/yaws/scripts'
                VARDIR='/usr/local/var' ./local-install true
                mkdir: cannot create directory `/usr/local/var/yaws': 
No such file or directory
                make[1]: *** [local_install] Error 1
                make[1]: Leaving directory 
`/home/gs/git-repos/yaws/scripts'
                make: *** [local_install] Error 2
                gs@flipper:~/git-repos/yaws$

I thought, referring to http://yaws.hyber.org/yaws.pdf (p7), that the 
yaws exec and the config will go in my home but that is not happening 
instead '/usr/local/var/' is the target.

Any ideas what I might be doing wrong.
Thanks,
George