Also, the names Guard and ValueGuard are leftovers from
days. I propose renaming ValueGuard to Guard and Guard
to -- something
I haven't thought of a decent name for Guard, though; just
ExtendedGuard, SugaredGuard, FancyGuard, etc., which
might be true but
don't really say anything.