Dear Hermet, Hi!
I have refined previous patch based on your opinion. Please refer to bellow
comments and attached patch
1. how about changing the signal names to ones more explicitly ?
I guess hide could be added also later.*
-> Names are changed as you mentioned.
I don't like that name. Since those signals are not only for transitions but
also any other actions.
How about just _show_signal_emit ?*
-> Also changed
*3. edje_object_signal_emit(wd->base, "elm,state,show", "elm"); in the
looks useless call. doesnt' it?*
-> edje_object_signal_emit(); should be there. The clip part does not come
properly without this.
2011/8/22 cnook <kimcinoo@...>
> Dear All, Hello!
> The transition effect is added to the ctxpopup when it comes.
> Please review the attached patch. Thanks always!
> Shinwoo Kim.