#264 encription fails if pgpagent is used

invalid
nobody
None
1.6.0
Major
30.0a1 (20140316030203)
1.7a1pre (20140316-0013)
All
---
2014-11-02
2014-03-16
Thomas Schweikle
No

Encrption fails if gpgagent is running. The passphrase is never asked about, even if it was never entered. Encription fails with error "Bad Passphrase".

Discussion

  • It does not help to enter the passphrase by calling any of the keyring tools directly. Same error: "Bad Passphrase" or "Incorrect Passphrase".

     
  • Encryption never takes a passphrase. Only signing (alone or combined with encryption) needs a passphrase. Please write exactly what you have done and when the error message pops up. Which operating system are you using?

     
  • Excuse me -- I meant signing.

    OS: Ubuntu 14.04 (trusty) x86_64

    ⟫ gpg --version
    gpg (GnuPG) 1.4.16
    Copyright (C) 2013 Free Software Foundation, Inc.
    License GPLv3+: GNU GPL version 3 or later
    http://gnu.org/licenses/gpl.html
    This is free software: you are free to change and redistribute it.
    There is NO WARRANTY, to the extent permitted by law.

    Home: ~/.gnupg
    Unterstützte Verfahren:
    Öff. Schlüssel: RSA, RSA-E, RSA-S, ELG-E, DSA
    Verschlü.: IDEA, 3DES, CAST5, BLOWFISH, AES, AES192, AES256, TWOFISH,
    CAMELLIA128, CAMELLIA192, CAMELLIA256
    Hash: MD5, SHA1, RIPEMD160, SHA256, SHA384, SHA512, SHA224
    Komprimierung: nicht komprimiert, ZIP, ZLIB, BZIP2

     
  • Please enable the debug log file, repeat the tests and search for "problem with gpg-agent" or "problem with pinentry".

    Instructions for enabling the debug log are here: https://www.enigmail.net/support/bugs.php

     
  • No reply from reported; nothing to analyze or fix.

     
    • status: open --> invalid