Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

emu10k1-v0.20a and 2.6.17.1 compilation

Help
2006-09-15
2012-07-08
  • Volkan YAZICI
    Volkan YAZICI
    2006-09-15

    Hi,

    When I try to compile emu10k1-v0.20a, after make completes succesfully with

    shell# make
    make -Cscripts
    make[1]: Entering directory /root/emu10k1/emu10k1-v0.20a/scripts' cc -I/lib/modules/uname -r/build/include get_version.c -o get_version make -f /root/emu10k1/emu10k1-v0.20a/scripts/Makefile.get_options -C /lib/modules/uname -r/build get_version_target make[2]: Entering directory/home/kernel/linux-2.6.17.1'
    echo "KERNEL_VERSION := 2.6.17.1" >> /root/emu10k1/emu10k1-v0.20a/scripts/../.opts
    echo "CFLAGS += -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -O2 -fomit-frame-pointer -pipe -msoft-float -mpreferred-stack-boundary=2 -march=i386 -ffreestanding -Iinclude/asm-i386/mach-default " >> /root/emu10k1/emu10k1-v0.20a/scripts/../.opts
    echo "CC := gcc -m32" >> /root/emu10k1/emu10k1-v0.20a/scripts/../.opts
    echo "MODFLAGS += -DMODULE" >> /root/emu10k1/emu10k1-v0.20a/scripts/../.opts
    make[2]: Leaving directory /home/kernel/linux-2.6.17.1' make[1]: Leaving directory/root/emu10k1/emu10k1-v0.20a/scripts'

    Compilation configured for KERNEL_VERSION := 2.6.17.1, now compile it with:
    make

    message, second make generates lots of unmet header file dependencies:

    shell# make
    gcc -m32 -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -O2 -fomit-frame-pointer -pipe -msoft-float -mpreferred-stack-boundary=2 -march=i386 -ffreestanding -Iinclude/asm-i386/mach-default -DMODULE -M audio.c cardmi.c cardmo.c cardwi.c cardwo.c efxmgr.c emuadxmg.c hwaccess.c irqmgr.c main.c midi.c mixer.c recmgr.c timer.c voicemgr.c ecard.c passthrough.c > .depend
    In file included from /usr/include/asm/smp.h:18,
    from /usr/include/linux/smp.h:17,
    from /usr/include/linux/sched.h:23,
    from /usr/include/linux/module.h:10,
    from audio.c:34:
    /usr/include/asm/mpspec.h:6:25: mach_mpspec.h: No such file or directory
    In file included from /usr/include/linux/smp.h:17,
    from /usr/include/linux/sched.h:23,
    from /usr/include/linux/module.h:10,
    ...

    I tried to solve above dependency problems by adding extra -I flags to the cc, but after a point (it required linux/wrapper.h, which is redundant for 2.6 series) it started to raise more and more dependency (or syntax) error exceptions. (I tried cvs tip too, with no luck. Same errors.) Looks like emu-tools suffering from the similar problems.

    Isn't it possible to compile emu10k1 on 2.6.17.X or am I just missing an obvious step?

    I'll be very appreciated if you can help me to figure out the problem.

    Regards.