#384 Package "glade-gtk2" from Ubuntu Trusty for Debian Wheezy

2.6
open-accepted
None
5
2014-08-02
2014-07-30
Jeff Epler
No

In LinuxCNC 2.6, the .glade and .ui files can only be edited by a version of glade older than the one packaged in Debian Wheezy. This package is in Ubuntu Trusty with binary package name "glade-gtk2", source package name "glade-3". The package seems to build properly and function without modification (tested on a wheezy amd64 machine); build the packages at least for i386 and amd64 and put them on www.l.o.

Discussion

    • status: open --> closed-fixed
     
  • Built debs for wheezy i386 & amd64, uploaded to linuxcnc.org deb archive.

     
  • Chris Radek
    Chris Radek
    2014-08-01

    • status: closed-fixed --> open-accepted
     
  • Chris Radek
    Chris Radek
    2014-08-01

    I'm reopening because we still need to figure out how we want to get this installed. I think the choices that make sense are versioned runtime dependency on linuxcnc, or a manual package addition on the live cd.

     
  • Jeff Epler
    Jeff Epler
    2014-08-02

    This package is not needed to build linuxcnc, and it is not needed to run linuxcnc. It's needed by a minority of users who want to edit .glade / .ui files.

    At most, the main linuxcnc package should recommend or suggest it. It need not depend on it.

     
    • Seems like linuxcnc-dev should Build-Recommend gnome-glade. Too bad
      there is no Build-Recommends field in debian/control files :-(

       
  • Jeff Epler
    Jeff Epler
    2014-08-02

    As far as what package to recommend, glade-gnome looks correct for Ubuntu (lucid through trusty) and Debian (squeeze; and, with our port, wheezy)