The 2gb max file size & editing Mjpeg?

2005-01-25
2013-06-03
1 2 3 > >> (Page 1 of 3)
  • Im using the 313L camera to film cycle races in HD which will be linked to software & a indoor cycle trainer. The two questions I have after capturing some great looking mjpeg.avi are .......

    1: Is it possible to record past 2gb with the Knoppix CD (NTFS?).

    2: Is there a way to edit the mjpeg avi files in windows XP?

    Regards Phil

     
    • 1. Before record to NTFS partition configure "captive" - look item in Knoppix menu.

       
      • As writing to NTFS system is experimental in GNU/Linux (due to secrecy in NTFS format) it is generally not considered safe to write to  I would recommend to either use additional hard drive or repartition the current one so it will have FAT32  partition (in addition no the main one with NTFS) -  file system that is safe to write from GNU/Linux and it is definitely readable from Windows XP.
        The files recorded from the camera are motion JPEG compatible with Apple Quicktime (so it definitely understands the format). I've never tested myself but I know that there are 3-rd party codecs for Windows Media Player that make it understand Apple Quicktime MJPEG.

        Andrey

         
    • Great thanks very much for pointing me in the right direction! I will try a USB2 external NTFS hard drive.

      For the second problem I can not open these avi files even with Apple quicktime with XP. I can play them with Mplayer though.

      Can you say how the two .mov demo videos on the elphel website were recorded? I have no problem with these files & I can edit & play them on just about every video related program on my PC.

      As soon as I solve this last hurdle I think I can go away a happy film maker!

       
      • > I will try a USB2 external NTFS hard drive

        Did you external USB FAT32 hard drive? NTFS is not safe to write from GNU/linux.

         
    • Phil
      Phil
      2005-01-26

      >Did you external USB FAT32 hard drive? NTFS is not safe to write from GNU/linux.<

      Not yet so far Ive only used the Fat32 internal hard drive of the laptop.

      I put a little demo clip of avi (its my front room) here, 

      www.tacx-video.com/video.avi 

      Can anyone tell me why it does not play on anything other then Mplayer?

      Thanks again Phil

       
    • Is there any possibilty to re-encoding the *.avi to other more friendly format to quicktime or realplayer with mencoder?

      Larry

       
    • Phil
      Phil
      2005-01-27

      Ive tried Mewig in windows as it can play the file but nothing happens & it appears to just hang the program. (perhaps it can not handle the HD size video?) I'm not familiar with Mencoder or Linux so I was hoping that I had made a fault. 

      For the moment it looks to me that the avi files that I make are not a user friendly version of Mjpeg. Could the choice of streamer affect the file codec? Is it possible to create a .mov file with Mencoder & the stream comming from the camera?

      Thanks Phil

       
      • Try recode file with next command

        mencoder video.avi -ovc lavc -o video.mov

        where file "video.avi" - source, "video.mov" - destination (MPEG-4)

         
    • Phil
      Phil
      2005-01-27

      I tried this & got a load of errors about not being able to open the mplayer/codecs.conf

      then File not found frameno.avi (do I need to make a template text file or such?)

      Then it can not find the config file of Mencoder

      Then lastly it does not understand my attempts of code! 

      (unknown suboption     mencoder mnt/hda1/video4.avi -ovc lavc -o mnt/hda1/video5.mov

       
      • >File not found frameno.avi (do I need to make a template text file or such?)

        ignore this message

        Please, show full text on your terminal inluding the command line.

         
    • I used the following command on a stream:

      mencoder rtsp://192.168.0.9:7070 -ovc lavc -o /mnt/hda1/video4.mov -fps 25

      It made a .mov named file but this file will again only play in Mplayer?

       
      • Running mencoder directly from the camera stream and compressing in real time not work - it is too computationally complex task for the computer. If you are using full resolution/frame rate the only way is to record first with  "-ovc copy" and then trascode test.avi (default output file if you did not specify something different) into some other format.

         
    • Phil
      Phil
      2005-01-27

      Ive got the camera working in windows now with Quicktime so its not a codec problem, Im guessing now its either something with the settings Ive made in Knoppix or the way mplayer makes the avi file?

       
    • Latin Andy
      Latin Andy
      2005-01-28

      You can try make:

      mencoder video.avi -o recoded_avi -ovc lavc -lavcopts vcodec=mpeg4:vhq:vbitrate=4000

      It is working on Old players and Windows players - tested

      Problem in your files here:

      VIDEO:  [MJPG]  0x0  0bpp  25.000 fps
      -17179870.0 kbps (-2097152.0 kbyte/s)
      [V] filefmt:3  fourcc:0x47504A4D  size:0x0  fps:25.00  ftime:=0.0400

      bitrate not set and size of picture not set!
      WindowsPlayer can't undestend it

       
      • What could be the original problem with the file? Could it be because  these dimensions do not come from one of the streamers (the one that Phil used - which one?) and mencoder just copied "as is " and Mplayer just guessed the missing parameters? In that case just using the other streamer should correct the problem.

         
    • Latin Andy
      Latin Andy
      2005-01-28

      Or You can try it:

      mplayer -vo jpeg video.avi

      You got a lot of JPEG files and then assemble it (videoframes) in some VideoEditor  to file ...

       
    • Phil
      Phil
      2005-01-28

      knoppix@ttyp0[knoppix]$ mencoder rtsp://192.168.0.9:7070 -ovc copy -o /mnt/hda1/28jan.avi -fps 25
      MEncoder 1.0pre4-3.3.3 (C) 2000-2004 MPlayer Team

      CPU: Intel Pentium 4/Xeon/Celeron Foster 1994 MHz (Family: 8, Stepping: 9)
      Detected cache-line size is 64 bytes
      MMX2 supported but disabled
      SSE supported but disabled
      SSE2 supported but disabled
      CPUflags: Type: 8 MMX: 1 MMX2: 0 3DNow: 0 3DNow2: 0 SSE: 0 SSE2: 0
      Compiled for x86 CPU with extensions: MMX

      Reading /home/knoppix/.mplayer/codecs.conf: Can't open '/home/knoppix/.mplayer/codecs.conf': No such file or directory
      Reading /usr/local/etc/mplayer/codecs.conf: Can't open '/usr/local/etc/mplayer/codecs.conf': No such file or directory
      Using built-in default codecs.conf.
      File not found: 'frameno.avi'
      Failed to open frameno.avi
      Reading config file /home/knoppix/.mplayer/mencoder: No such file or directory
      font: can't open file: /home/knoppix/.mplayer/font/font.desc
      font: can't open file: /usr/local/share/mplayer/font/font.desc
      Connecting to server 192.168.0.9[192.168.0.9]:7070 ...
      rtsp_session: Not a Real server. Server type is 'unknown'.
      Not a Realmedia rtsp url. Trying standard rtsp protocol.
      Connected to server: 192.168.0.9
      success: format: 21  data: 0x0 - 0x0
      Stream not seekable!
      Initiated "video/JPEG" RTP subsession
      [V] filefmt:21  fourcc:0x47504A4D  size:0x0  fps: 0.00  ftime:=0.0000
      input fps will be interpreted as 25.00 instead
      videocodec: framecopy (0x0 0bpp fourcc=47504a4d)
      Writing AVI header...
      ODML: Aspect information not (yet?) available or unspecified, not writing vprp header.
      BasicTaskScheduler::SingleStep(): select() fails: Interrupted system call

       
      • > BasicTaskScheduler::SingleStep(): select() fails: Interrupted system call

        This message is about error which will be fixed in the future version of LiveCD. All other lines are correct.
        This error cause uncompletted header in the output file.

        Now please write similar report about attemts of translation file (/mnt/hda1/28jan.avi) to other video formats.

         
    • Phil
      Phil
      2005-01-28

      I think Ive tried all the 7 streamers now & non of them write a usable file (or mencoder can not create a usable file from a stream?). mplayer always plays them though.

      I do not know anything about the command lines which need to be entered so this line needs to be elaborated a bit for me.

      mplayer -vo jpeg video.avi

      My hard drive is = /mnt/hda1/
      My stream is = rtsp://192.168.0.9:7070

      How should I write this into the console? Ive tried & I just get errors. Just raw jpeg images will be fine if I can also play the stream with mplayer live like now to see the picture quality etc.

      I also tried -dumpstream but got errors with this also.

      Im amazed that I seem to be the only person with this camera that wants to record & edit the wonderful video it can create?!

      regards & thanks for helping me here

      Phil

       
      • >Just raw jpeg images will be fine if I can also play the stream with mplayer live like now to see the picture quality etc. 

        You can run two mplayers with some rtp url in parallel.
        First for watch and second for write to disk.

         
    • Phil
      Phil
      2005-01-28

      >You can run two mplayers with some rtp url in parallel.
      First for watch and second for write to disk. <

      Can you write a command line that I can just copy & paste? :-I

      My hard drive is = /mnt/hda1/
      The stream is (I think) = rtsp://192.168.0.9:7070 

      Regards Phil

      I will get that error text for you now.

       
      • Open two xterminals

        In first window type

        mplayer -vo x11 rtsp://192.168.0.9:7070

        In second window type

        cd /mnt/hda1/
        mkdir video
        cd video
        mencoder -ovc copy -fps 25 rtsp://192.168.0.9:7070

        After some time to stop recording press Ctrl+C
        Then type

        mplayer -vo jpeg test.avi

        To view  multiple jpeg files type

        mplayer -vo x11 'mf://*.jpg' -fps 25

        To translate jpegs to avi format type

        mencoder  -ovc lavc -fps 25 'mf://*.jpg' -lavcopts vcodec=mjpeg scale=1280:1024 -o video.avi

        landy_ wrote:
        >mplayer -vo jpeg rtsp://...
        ...
        >mencoder -ovc lavc -lavcopts vcodec=mjpeg -vf scale=1280:1024 rtsp://192.168.0.9:7070
        -o video.avi

        Its correct but mplayer and mencoder may skip frames because CPU 2GHz is too slow for code jpeg in real time.

         
    • Latin Andy
      Latin Andy
      2005-01-28

      I think you can make output file in 2-step:

      1. mplayer -vo jpeg rtsp://....
      2. mencoder mf://*.jpg -mf fps=25:width=1280:height=1024 -o output.avi

      or(but may be possible with landys streamer, may be not, try it pls with othe stramers)

      mencoder elphel://unicast_ip:port -elphel fps=25:w=1280:h=1024 -o output.avi

       
    • Latin Andy
      Latin Andy
      2005-01-28

      It can working also

      mencoder -ovc lavc -lavcopts vcodec=mjpeg -vf scale=1280:1024 rtsp://192.168.0.9:7070 -o video.avi

       
1 2 3 > >> (Page 1 of 3)