Problem with service ExternalRA on CA

anhvh
2013-01-14
2013-02-18
  • anhvh
    anhvh
    2013-01-14

    hi everyone

    I run a CA with EJBCA 4.0.12 and JBOSS 5.1. I have config a service ExternalRA, while run server ExternalRA, i see a notice:

    2013-01-14 08:50:50,545 INFO   (EJB-Timer-1357573724540) Service org.ejbca.extra.caservice.ExtRACAServiceWorker with name BkavCA External RA 1  is already running in this VM! Not starting work
    Then ExternalRA service don't scan database RA. I don't know this error. i hope u can help me fix this error.
    Thanks u!

     

  • Anonymous
    2013-01-14

    It seems that the EJBCA service is "hanging" for some reason.  This could be due to a database connection issue. Check that the database is available from the EJBCA box.  Also check for ERRORs in the server logs.

    Cheers
    Anders
    Tech support

     
  • anhvh
    anhvh
    2013-01-15

    i was checked log server CA, but i only see notice
    "2013-01-14 08:50:50,545 INFO   (EJB-Timer-1357573724540) Service org.ejbca.extra.caservice.ExtRACAServiceWorker with name BkavCA External RA 1  is already running in this VM! Not starting work"
    i have added a module ExternalRA (extra_3.9) trong folder EJBCA. but i know, From EJBCA 3.10 the External RA API is bundled as a part of EJBCA and can be enabled in conf/externalra.properties. so, that must be a reason ???

     
  • anhvh
    anhvh
    2013-01-15

    i see a notice :

    WARN: Service "BkavCA External RA 1" took longer that it"s configure service interval. This can trigger simultanious service excution on serveral node in a cluster. Increase interval or lower each invocation work load

    help me!

     

  • Anonymous
    2013-01-15

    You are talking about 3.9, 3.10 and 4.12.  I would not mix versions to begin with.

    Anyway, the message you get is because the service is hindered from performing its task.  There should be something indication of what in the log before this occur.

    Cheers
    Anders
    tech support

     
  • anhvh
    anhvh
    2013-01-25

    :( .. i can't fix this problem, This problem often occurs. i often have to restart Jboss, then service ExternalRA  run normally.