deploy error

Help
cyberuser
2014-04-03
2014-04-09
  • cyberuser
    cyberuser
    2014-04-03

    I get the following error when I enter "ant deploy":

    14:54:54,995 ERROR [org.jboss.as.controller.management-operation] (management-handler-thread - 1) JBAS014612: Operation ("composite") failed - address: ([]): java.lang.IllegalArgumentException
        at org.jboss.dmr.ModelValue.asList(ModelValue.java:128) [jboss-dmr-1.1.1.Final.jar:1.1.1.Final]
        at org.jboss.dmr.ModelNode.asList(ModelNode.java:1205) [jboss-dmr-1.1.1.Final.jar:1.1.1.Final]
        at org.jboss.as.controller.CompositeOperationHandler.execute(CompositeOperationHandler.java:58) [jboss-as-controller-7.1.1.Final.jar:7.1.1.Final]
        at org.jboss.as.controller.AbstractOperationContext.executeStep(AbstractOperationContext.java:385) [jboss-as-controller-7.1.1.Final.jar:7.1.1.Final]
        at org.jboss.as.controller.AbstractOperationContext.doCompleteStep(AbstractOperationContext.java:272) [jboss-as-controller-7.1.1.Final.jar:7.1.1.Final]
        at org.jboss.as.controller.AbstractOperationContext.completeStep(AbstractOperationContext.java:200) [jboss-as-controller-7.1.1.Final.jar:7.1.1.Final]
        at org.jboss.as.controller.ModelControllerImpl$DefaultPrepareStepHandler.execute(ModelControllerImpl.java:466) [jboss-as-controller-7.1.1.Final.jar:7.1.1.Final]
        at org.jboss.as.controller.AbstractOperationContext.executeStep(AbstractOperationContext.java:385) [jboss-as-controller-7.1.1.Final.jar:7.1.1.Final]
        at org.jboss.as.controller.AbstractOperationContext.doCompleteStep(AbstractOperationContext.java:272) [jboss-as-controller-7.1.1.Final.jar:7.1.1.Final]
        at org.jboss.as.controller.AbstractOperationContext.completeStep(AbstractOperationContext.java:200) [jboss-as-controller-7.1.1.Final.jar:7.1.1.Final]
        at org.jboss.as.controller.ModelControllerImpl.execute(ModelControllerImpl.java:121) [jboss-as-controller-7.1.1.Final.jar:7.1.1.Final]
        at org.jboss.as.controller.remote.ModelControllerClientOperationHandler$ExecuteRequestHandler.doExecute(ModelControllerClientOperationHandler.java:139) [jboss-as-controller-7.1.1.Final.jar:7.1.1.Final]
        at org.jboss.as.controller.remote.ModelControllerClientOperationHandler$ExecuteRequestHandler$1.execute(ModelControllerClientOperationHandler.java:108) [jboss-as-controller-7.1.1.Final.jar:7.1.1.Final]
        at org.jboss.as.protocol.mgmt.AbstractMessageHandler$2$1.doExecute(AbstractMessageHandler.java:287) [jboss-as-protocol-7.1.1.Final.jar:7.1.1.Final]
        at org.jboss.as.protocol.mgmt.AbstractMessageHandler$AsyncTaskRunner.run(AbstractMessageHandler.java:487) [jboss-as-protocol-7.1.1.Final.jar:7.1.1.Final]
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) [rt.jar:1.7.0_51]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) [rt.jar:1.7.0_51]
        at java.lang.Thread.run(Thread.java:744) [rt.jar:1.7.0_51]
        at org.jboss.threads.JBossThread.run(JBossThread.java:122) [jboss-threads-2.0.0.GA.jar:2.0.0.GA]
    

    The task result is "BUILD SUCCESSFUL".

    Does anyone know the cause for the error?

     
  • Frazze
    Frazze
    2014-04-06

    Did you find a solution to the problem? Because I have the exactly same error in my log file and could not yet find a solution ...

     
    Last edit: Frazze 2014-04-06
  • In order to finish ant deploy sucesfully you need to have more than one core, and sufficient RAM, i.e. enough erformance in the machine. No 1 core virtual machines work with JBoss 7 (this is stated by RedHat support).

    Cheers,
    Tomas


    PrimeKey Solutions offers commercial EJBCA and SignServer support subscriptions and training courses. Please see www.primekey.se or contact info@primekey.se for more information.
    http://www.primekey.se/Services/Support/
    http://www.primekey.se/Services/Training/

     
  • Frazze
    Frazze
    2014-04-06

    I tested it on a VM with 2 cores and 4gb memory of which 2gb have been assigned solely to java.
    Still same problem though

     
  • cyberuser
    cyberuser
    2014-04-09

    I tested it on a VM with 8 gb ram an 4 cores.
    still the same problem.

     
  • Obviously your problem is something else. Most likely due to your specific configuration (you don't say any details in the issue could be windows you are running?).
    Do a "pure" default installation according to quick start first.

     
    • cyberuser
      cyberuser
      2014-04-09

      My environment:

      OS        -> openSUSE 13.1 (Bottle) (x86_64)
      RAM       -> 8GB
      CPU-Cores -> 4
      
      jboss-as-7.1.1.Final
      
      ejbca_ce_6_1_1
      
      jdk1.7.0_51
      
       
  • This particular error you get I also get in the log during ant deploy. But it does not matter and everything works fine.
    I will assume this is due to a bug in JBoss.

    I assumed something was not working for you, and not that you only asked for the reason of this error. Sorry for misunderstanding. EJBCA works as it should and you can ignore that message, it will not appear again.

    Cheers,
    Tomas

     
    • cyberuser
      cyberuser
      2014-04-09

      thanks for the info Tomas!