Deployment Fails

Help
mkdigital
2012-11-12
2013-02-18
  • mkdigital
    mkdigital
    2012-11-12

    starting jboss after running ant bootstrap yields an error in the jboss console

    im using jboss 5.1.0GA with ejbca 4.0.12 and java version "1.7.0_09"
    OpenJDK Runtime Environment (IcedTea7 2.3.3)

    i read of a similar error when using java 1.7, so i set the source and target switch to 1.6

    java.lang.StackTraceElement does not have a no-arg default constructor.
    this problem is related to the following location:
    at java.lang.StackTraceElement
    at public java.lang.StackTraceElement java.lang.Throwable.getStackTrace()
    at java.lang.Throwable
    at private java.lang.Throwable org.ejbca.core.protocol.ws.jaxws.AuthorizationDeniedExceptionBean.suppressed
    at org.ejbca.core.protocol.ws.jaxws.AuthorizationDeniedExceptionBean

    at com.sun.xml.bind.v2.runtime.IllegalAnnotationsException$Builder.check(IllegalAnnotationsException.java:102)
    at com.sun.xml.bind.v2.runtime.JAXBContextImpl.getTypeInfoSet(JAXBContextImpl.java:448)
    at com.sun.xml.bind.v2.runtime.JAXBContextImpl.<init>(JAXBContextImpl.java:297)
    at com.sun.xml.bind.v2.ContextFactory.createContext(ContextFactory.java:139)
    at com.sun.xml.bind.api.JAXBRIContext.newInstance(JAXBRIContext.java:105)
    at org.jboss.ws.core.jaxws.CustomizableJAXBContextFactory.createContext(CustomizableJAXBContextFactory.java:108)
    … 41 more

     

  • Anonymous
    2012-11-12

    Hi,
    EJBCA isn't officially qualified for use with JDK 7 (yet) so I think you have to downgrade your java installation first.

    Cheers
    anders
    tech support

     
  • mkdigital
    mkdigital
    2012-11-14

    turns out it was not the JDK7, but the wrong tomcat version. i used 5.10, it works under 6.10

     

  • Anonymous
    2012-11-14

    I'm not sure I understood that.  EJBCA uses the Tomcat that comes bundled with JBoss.

    Cheers,
    Anders
    tech support

     
  • mkdigital
    mkdigital
    2012-11-14

    sorry, i mistyped, i meant wrong jboss version. with 5.10 the above error occured, with 6.10 it worked. your onlinedoku says it works with 5.10 though.