Ticket modified by Nina Kuckländer at 2014/02/11 14:48
Tracking SystemBugs
CategorySetup
VersionVersion 1.8.004
StatusOpen
ResolutionNone
Completed0%
Priority5 - medium
Created byKlaus Jänsch
Created on2013/07/22 11:25
Assigned toRalf Becker
Summary#3237 - PHP 5.3 Dependency problem on SLES 11 SP2
Hello,

Since last update to version 1.8.004.20130620
I get the following messages in Apache Logfile:

PHP Parse error: syntax error, unexpected T_PAAMAYIM_NEKUDOTAYIM in
/usr/share/egroupware/emailadmin/inc/class.emailadmin_bo.inc.php on line 883

I cannot edit any user account.

OS: SuSE Linux Enerprise 11 SP2

I found out that the syntax error is caused by running PHP Version 5.2 and that
I should upgrade to PHP 5.3. The server is running SLES 11 SP2 and SP2 provides
php53 packages. So I tried to upgrade:

zypper in php53
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: php53-5.3.17-0.13.7.i586 conflicts with php5 < 5.3 provided by
php5-5.2.14-0.7.30.46.1.i586
Solution 1: Following actions will be done:
deinstallation of php5-5.2.14-0.7.30.46.1.i586
deinstallation of php5-ldap-5.2.14-0.7.30.46.1.i586
...
deinstallation of php5-imap-5.2.14-0.7.30.46.1.i586
deinstallation of jpgraph-3.0.7-3.1.noarch
deinstallation of apache2-mod_php5-5.2.14-0.7.30.46.1.i586
deinstallation of eGroupware-core-1.8.004.20130620-1.1.noarch
deinstallation of php5-pear-5.2.14-0.7.30.46.1.i586
deinstallation of eGroupware-projectmanager-1.8.004.20130620-1.1.noarch
deinstallation of eGroupware-calendar-1.8.004.20130620-1.1.noarch
deinstallation of eGroupware-bookmarks-1.8.004.20130620-1.1.noarch
deinstallation of eGroupware-1.8.004.20130620-1.1.noarch
deinstallation of eGroupware-egw-pear-1.8.004.20130620-1.1.noarch
deinstallation of eGroupware-emailadmin-1.8.004.20130620-1.1.noarch
...
deinstallation of eGroupware-wiki-1.8.004.20130620-1.1.noarch
Solution 2: do not install php53-5.3.17-0.13.7.i586

Choose from above solutions by number or cancel [1/2/c] (c):


Egroupware code seems to require PHP 5.3 but the RPM package requires SLES php5 (PHP
5.2) packages.


rpm -q --requires eGroupware-core
php >= 5.2.1
php-mbstring
php-gd
php-mcrypt
php-pear
php-posix
apache2
apache2-mod_php5
php_any_db
php5-dom
php5-bz2
php5-openssl
php5-zip
php5-ctype
php5-sqlite
cron
zip
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(CompressedFileNames) <= 3.0.4-1
/usr/bin/php
rpmlib(PayloadIsLzma) <= 4.4.2-1

Klaus
Comment by Nina Kuckländer at 2014/02/11 14:48:
I can confirm this with SLES 11 SP3 and eGW 1.8.005.20131007-1.1 from download.opensuse.org/repositories/server:/eGroupWare/SLE_11_SP3/

#### YaST2 conflicts list - generated 2014-02-11 14:46:14 ####

nothing provides apache2-mod_php5 needed by eGroupware-core-1.8.005.20131007-1.1.noarch

[ ] do not install eGroupware-1.8.005.20131007-1.1.noarch

[ ] break eGroupware-core-1.8.005.20131007-1.1.noarch by ignoring some of its dependencies

I wonder how this compiled ok for SP3 because only apache-mod_php53 exists.



Linked entries:
Bugs #3237: PHP 5.3 Dependency problem on SLES 11 SP2